Générer lien hypertexte en résultat d'une formule =SI( [Résolu]

Signaler
Messages postés
4
Date d'inscription
mercredi 14 octobre 2020
Statut
Membre
Dernière intervention
14 octobre 2020
-
Messages postés
2815
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 octobre 2020
-
Bonjour à tous et à toutes,

Je suis actuellement en cours de création d'un tableau dans le cadre de mon activité professionnelle et j'aurais besoin de votre aide car je n'arrive pas à faire ce que je voudrais.

Je voudrais faire apparaitre un lien hypertexte en fonction d'un résultat obtenu suite à une formule =SI(, ce lien hypertexte devra me renvoyer vers une autre feuille du même classeur.

Je n'arrive pas à trouver la solution sur le forum, et je précise que je ne suis pas un dieu d'excel, loin de la :)

Si besoin j'ai le fichier à disposition.

Merci d'avance pour votre aide.

4 réponses

Messages postés
2815
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 octobre 2020
753
Bonjour,

Une recherche sur le forum aurait menée >>>ICI<<<

Si tu ne trouves pas la réponse à ta question, alors oui le fichier est à joindre à la réponse

Cordialement
Messages postés
4
Date d'inscription
mercredi 14 octobre 2020
Statut
Membre
Dernière intervention
14 octobre 2020

Merci pour ta réponse,

Non je n'ai pas trouvé ce qu'il me faut.

voici le lien de mon tableau:

https://www.cjoint.com/c/JJoovAmqHDN
Messages postés
2140
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
15 octobre 2020
847
Bonsoir
une proposition en C5
=LIEN.HYPERTEXTE("#"&A3&" "&A5&" "&A7&".A1";"aller feuille"&A3&" "&A5&" "&A7)
Messages postés
4
Date d'inscription
mercredi 14 octobre 2020
Statut
Membre
Dernière intervention
14 octobre 2020

Merci
J'ai copier mais cela ne fonctionne pas :-(
Messages postés
2140
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
15 octobre 2020
847
re
mettre !A1
au lieu de
.A1
Messages postés
2815
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 octobre 2020
753 >
Messages postés
2140
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
15 octobre 2020

Salut Yclik

Je n'avais pas encore testé la formule et chez mois non plus ça ne fonctionnait pas malgré la correction !A1 ; en fait ça vient du point entre LIEN et HYPERTEXTE qu'il fallait remplacer par le trait de soulignement LIEN_HYPERTEXTE

Cordialement
Messages postés
2815
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
16 octobre 2020
753
Re:

Un autre exemple avec cette formule en E5

=LIEN_HYPERTEXTE(STXT(CELLULE("filename");TROUVE("[";CELLULE("filename"));SOMME(TROUVE({"[";"]"};CELLULE("filename"))*{-1;1})+1)&"'"&C5&"'!A1";C5)


https://www.cjoint.com/c/JJoqmD3N4Zq

Dans le fichier retour, la cellule E5 est sélectionnée, clic dans la barre de formule puis sur "Enter" pour réactiver le lien

Cordialement
Messages postés
4
Date d'inscription
mercredi 14 octobre 2020
Statut
Membre
Dernière intervention
14 octobre 2020

Ca fonctionne !!!!!!

Merci beaucoup tu es au top !!!
Merci également a toi yclick !!!

J'y serais jamais arrivée sans vous