Garder systematiquement un format hh:mm:ss même s'il s'agit de moins d'une heure

Signaler
-
 Damien -
Bonjour à tous,

J'aimerais savoir si vous auriez une idée/solution pour résoudre mon problème.

j'ai besoin de faire des calculs avec des données sous forme d'heures que j'extrait d'un outil qui ne me les donne pas toujours sous la forme hh:mm:ss.
En fait il ne me donne cette forme que s'il s'agit d'une valeur supérieure à 1 heure (ex 01:12:23).
S'il s'agit d'une valeur < 1h, l'outil me donne :mm:ss (ex: :12:23).
Je suis donc obligé de rajouter les heures manuellement pour que mes calculs fonctionnent.
Je ne peux pas paramétrer mon outil malheureusement.
Ma question est: "est-il possible de faire en sorte qu'Excel ajoute systématiquement 00 lorsque mon extraction est <1 heure ?"
D'avance merci de votre aide

Configuration: Windows / Internet Explorer 11.0

2 réponses

Messages postés
12758
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2020
2 041
Bonjour Damien

Avec les durées extraites en colonne A, en B1 mettre la formule :
=SI(GAUCHE(A1;1)=":";TEMPSVAL("00"&A1);A1)
et étirer vers le bas

Tu peux ensuite copier la colonne B et la copier par collage spécial Valeurs où tu veux

Cdlmnt
Via
T’es un/e as, Merci beaucoup via.
Ça fonctionne parfaitement.