Année bissextile [Résolu]

Signaler
Messages postés
4
Date d'inscription
vendredi 9 octobre 2020
Statut
Membre
Dernière intervention
10 octobre 2020
-
Messages postés
4
Date d'inscription
vendredi 9 octobre 2020
Statut
Membre
Dernière intervention
10 octobre 2020
-
Bonjour,
je n'arrive pas à résoudre ce problème d'année bissextile dans mon tableau qui est différent du calendrier.

Merci pour votre aide
Garnay

3 réponses

Messages postés
2793
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 octobre 2020
381
Bonjour,

Un fichier (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question.

Crdmt
Messages postés
4
Date d'inscription
vendredi 9 octobre 2020
Statut
Membre
Dernière intervention
10 octobre 2020

Bonjour
j'aimerai que la date du 30 juin reste dans les cellules du premier tableau (A à I 365/366)
Année bissextile cette date se retrouve en cellule K5/6 (=A365+1) ; en N5 (=K5)
Année non bissextile la date du 1 juillet s'ajoute en A367 (=A365+1) et en N5 (=A365+1)
En espérant avoir été explicatif
Cordialement
G



https://www.cjoint.com/c/JJkkigKQ45b
Messages postés
2810
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
10 octobre 2020
752
Bonjour

Avec changement des formules des cellules A, B, C, D de la ligne 367 et de la cellule K5
pour que le tableau s'adapte aux années bissextiles

https://www.cjoint.com/c/JJkkP2wuJpn

Cordialement
Messages postés
4
Date d'inscription
vendredi 9 octobre 2020
Statut
Membre
Dernière intervention
10 octobre 2020

RE :
Merci Papyluc51 pour ton aide, mais pour les années bissextiles, il y a le 30 juin en K5
Cordialement
G
Messages postés
2810
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
10 octobre 2020
752
RE:

Tu n'as pas regardé ton fichier en retour avec les formules ci-dessous

A367 =SI(MOIS(A365+1)>MOIS(A365);"";A365+1)

B367 =SI(A367="";"";SI(D367="L";"S "&NO.SEMAINE(A365;2);""))

C367 =SI(A367="";"";C365+1)

D367 =SI(A367="";"";CHOISIR(JOURSEM(A367);"D";"L";"M";"M";"J";"V";"S"))

K5 =SI(A367<>"";A367+1;A365+1)

Cordialement
Messages postés
4
Date d'inscription
vendredi 9 octobre 2020
Statut
Membre
Dernière intervention
10 octobre 2020

RE :
Excuse moi, j'ai du me mélanger dans les fichiers, mais effectivement ca marche.
Merci encore et bon week
G