Problème Suppression [Résolu]

Signaler
-
Messages postés
1183
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
28 octobre 2020
-
Bonsoir tous le monde ,
- Actuellement j'ais rencontrais un problème dans mon ficher Excel :
je dispose d'une base de données qui contient le ( code produit - date d'achat produit - prix d'achat unité ) qui contient plus de 45000 lignes .
a chaque fois qu'une achat est effectuiez une ligne supplémentaire est ajouter ou ficher
mon problème C'est que :
a chaque fois que je veux récupérer le dernier prix d'achat pour tous les produits je suis obliger de trié mon ficher est de supprimer les ancien date d'achat pour garder que les derniers achat pour tous les produits manuellement sachons que la base contiens enivrant 3000 articles
as que il Ya un moyenne qui me périmer de données le code produits est qui me génère automatiquement la dernière date d'achat est le dernier prix d'achat
ou
une formule qui périmer de supprimer tous les doublant code produits mais qui puisse garder que la dernière date d'achat est le dernier prix d'achat .

JE VOUS REMERCIE

5 réponses

Messages postés
2169
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
22 octobre 2020
293
Bonjour,

Si j'ai bien compris, faites un tri descendant par date (de la plus récente à la plus ancienne), ainsi toutes les dernières valeurs seront en premières lignes.

Cdlt
Bonjour Mr Frenchie83 ,
-
ce que je veux avoir exactement une base qui contient tous mais produit ( code produits ) sans doublant avec la dernière date d'achat et le dernier prix d'achat pour chaque produits
en préff je veux supprimer tout les enceins date d'achat pour avoir aux finale une base qui contient tout mais produits sans doublant avec la dernier date d'achat et le dérnier prix d'achat qui est relié a la dernière date d'achat

exp :
Produit A Date : 03/09/2020 Prix U: 23.2
Produit A Date :02/09/2019 Prix U:15.18
Produit A Date :01/09/2018 Prix U:14.01
Produit B Date :12/08/2020 Prix U:33.2
Produit B Date :24/07/2020 Prix U:28.14
Produit B Date :01/01/2019 Prix U:26.01
Produit C Date :17/04/2020 Prix U:101.33
Produit C Date :22/03/2017 Prix U:203.2
Produit C Date :06/02/2016 Prix U:352.31
Produit D Date :15/06/2019 Prix U:141.4
Produit D Date :09/05/2020 Prix U:253.9
.
.
.

Résultat que je veux avoir :
Produit A Date : 03/09/2020 Prix A: 23.2
Produit B Date :12/08/2020 Prix A:33.2
Produit C Date :17/04/2020 Prix A:101.33
Produit D Date :15/06/2019 Prix A:141.4

espérant que vous aller comprendre mon problème


Je vous remercie Mr Frenchi83
Messages postés
1183
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
28 octobre 2020
117
Bonjour,
c'est possible en récupérant toutes les valeurs produits, les mettre dans une autre feuille (en colonne A par exemple) et ensuite supprimer les doublons.
Ensuite :
en colonne B : =RECHERCHEV(A1;Feuil1!A:C;2;1)
en colonne C : =RECHERCHEV(A1;Feuil1!A:C;3;1)

Un exemple :

https://www.cjoint.com/c/JIEkonxO01r
Bonjour Yoyo01000 ;

Merci Bq Frère C'est exactement ce que je charge
J'ais pensé a index & equiv ou Recherche V l'erreur que je faisait c t que a la place de 1 je m'étais un 0 de cout il me générer la date inferieure C'est pour cette raison que ca na pas marché :
RECHERCHEV(A1;Feuil1!A:B;2;0)
RECHERCHEV(A1;Feuil1!A:B;2;1)
Merci pour le coup de main Yoyo01000 ^^ =D
Messages postés
1183
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
28 octobre 2020
117
Si la solution apportée te convient, pense à mettre le sujet en [Résolu] ;)