Mise à jour d'un tableau en fonction d'une liste déroulante [Résolu]

Signaler
Messages postés
25
Date d'inscription
vendredi 16 décembre 2016
Statut
Membre
Dernière intervention
29 septembre 2020
-
Messages postés
52462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
-
Bonjour à tous,

j'ai extrait de mon logiciel pro un certain nombre d'éléments afin de faire une analyse commerciale un peu poussée.
Je vous joins un tableau afin d'illustrer ma demande.
https://www.cjoint.com/c/JIDmrRSQpCT
Je travaille pour une entreprise commerciale qui vend des produits qui sont catégorisés en famille article (ici, pommes, tomates, salades....). Je souhaiterai pouvoir voir d'un seul coup d'œil les volumes de vente ainsi que le CA engendré en fonction de mes clients et de la famille article.
J'ai créé une feuille avec le listing de mes clients. J'ai également fait une liste de mes articles afin de créer une liste déroulante.
Sur une seconde feuille (BDD), j'ai extrait de mon logiciel les volumes de ventes de chacun de mes clients en fonction de la famille article.
Je voudrais (avec une formule), que si je choisi par exemple "TOMATE" dans ma liste déroulante, le tableau se remplisse en fonction de ma BDD.

Merci d'avance pour votre aide!!



Configuration: Windows / Chrome 85.0.4183.121

3 réponses

Messages postés
25400
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 537
Bonjour
en C4:
=SOMME.SI.ENS(BDD!E:E;BDD!B:B;Feuil1!B4;BDD!C:C;Feuil1!$C$2)
en D4:
=SOMME.SI.ENS(BDD!E:E;BDD!B:B;Feuil1!B4;BDD!C:C;Feuil1!$C$2)
à tirer sur la hauteur utile
crdlmnt
Messages postés
52462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
14 330
En C4,
=SOMME.SI.ENS(BDD!$D$2:$D$26;BDD!$A$2:$A$26;A4;BDD!$C$2:$C$26;$C$2)

En D4,
=SOMME.SI.ENS(BDD!$E$2:$E$26;BDD!$A$2:$A$26;A4;BDD!$C$2:$C$26;$C$2)

Cordialement
Messages postés
52462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
14 330
T'inquiète pas, LulieCrazy : Vaucluse et moi sommes jumeaux spirituels !
(Mais pour C4, donne la préférence à ma référence D:D plutôt qu'à E:E ...)