Fonction recherche avancée

Résolu/Fermé
kilian29290 Messages postés 10 Date d'inscription dimanche 20 septembre 2020 Statut Membre Dernière intervention 21 décembre 2022 - 22 sept. 2020 à 16:48
kilian29290 Messages postés 10 Date d'inscription dimanche 20 septembre 2020 Statut Membre Dernière intervention 21 décembre 2022 - 7 oct. 2020 à 13:03
Bonjour,

je dispose d'un fichier dans lequel il y a 12 feuilles identiques au niveau forme mais différentes dans le contenue
ces 12 feuilles représentent les 12 mois de l'année et la hiérarchie de mon entreprise différente d'un mois à l'autre
elles s’appellent 1 2 3 etc jusqu'à 12
Dans une autre fuille jai dù faire une fonction qui fonctionne mais qui est tres lourde pour aller chercher en fonction du mois en cours la correspondance dans telle ou telle feuille.

n'y a t il pas plus simple?
$E$2= le nombre renvoyé par le mois en cours ( 1 pour janvier, 2 février etc etc)

=SI(E248="";"";SI(G248="";"";(SI($E$2=1;RECHERCHEV(E248;'1'!$G$6:$S$511;13;0);SI($E$2=2;RECHERCHEV(E248;'2'!$G$6:$S$511;13;0);SI($E$2=3;RECHERCHEV(E248;'3'!$G$6:$S$511;13;0);SI($E$2=4;RECHERCHEV(E248;'4'!$G$6:$S$511;13;0);SI($E$2=5;RECHERCHEV(E248;'5'!$G$6:$S$511;13;0);SI($E$2=6;RECHERCHEV(E248;'6'!$G$6:$S$511;13;0);SI($E$2=7;RECHERCHEV(E248;'7'!$G$6:$S$511;13;0);SI($E$2=8;RECHERCHEV(E248;'8'!$G$6:$S$511;13;0);SI($E$2=9;RECHERCHEV(E248;'9'!$G$6:$S$511;13;0);SI($E$2=10;RECHERCHEV(E248;'10'!$G$6:$S$511;13;0);SI($E$2=11;RECHERCHEV(E248;'11'!$G$6:$S$511;13;0);SI($E$2=12;RECHERCHEV(E248;'12'!$G$6:$S$511;13;0)))))

par avance merci

4 réponses

eriiic Messages postés 24496 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 7 février 2023 7 158
Modifié le 22 sept. 2020 à 17:08
Bonjour,

à tester :
=SI(OU(E3="";G3="");"";RECHERCHEV(E3;INDIRECT("'"&$E$2&"'!$G$6:$S$511");13;0))

pour simplifier j'ai remplacé la ligne 248 par la 3
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0
kilian29290 Messages postés 10 Date d'inscription dimanche 20 septembre 2020 Statut Membre Dernière intervention 21 décembre 2022
Modifié le 25 sept. 2020 à 14:36
super ca fonctionne, maintenant j'aimerai comprendre la formule, je ne la comprends pas
INDIRECT("'"&$E$2&"'!

pour m'aider à comprendre, pourrais tu m'ecrire cette formule?

=SI(SI($E$2=1;'1'!B8;SI($E$2=2;'2'!B8;SI($E$2=3;'3'!B8;SI($E$2=4;'4'!B8;SI($E$2=5;'5'!B8;SI($E$2=6;'6'!B8;SI($E$2=7;'7'!B8;SI($E$2=8;'8'!B8;SI($E$2=9;'9'!B8;SI($E$2=10;'10'!B8;SI($E$2=11;'11'!B8;SI($E$2=12;'12'!B8))))))))))))=0;"";SI($E$2=1;'1'!B8;SI($E$2=2;'2'!B8;SI($E$2=3;'3'!B8;SI($E$2=4;'4'!B8;SI($E$2=5;'5'!B8;SI($E$2=6;'6'!B8;SI($E$2=7;'7'!B8;SI($E$2=8;'8'!B8;SI($E$2=9;'9'!B8;SI($E$2=10;'10'!B8;SI($E$2=11;'11'!B8;SI($E$2=12;'12'!B8)))))))))))))
0
eriiic Messages postés 24496 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 7 février 2023 7 158
25 sept. 2020 à 17:11
Oui, bonjour aussi !

Regarde l'aide sur indirect, je ne saurai expliquer mieux. Ca devrait être un réflexe...
Ici je m'en sers pour faire varier le nom de la feuille récupéré en E2.
eric
0
kilian29290 Messages postés 10 Date d'inscription dimanche 20 septembre 2020 Statut Membre Dernière intervention 21 décembre 2022
7 oct. 2020 à 13:03
Super, j'ai appri pas mal sur cette fonction
cependant je n'arrive pas à faire dérouler vers le bas
=INDIRECT("'"&$C$2&"'!F9") pour que ce soit F10 F11 F12 etc tout en gardant C2 :(
0