Réaliser une RechercheV dans 3 colonnes

Résolu/Fermé
Valerie54001 Messages postés 130 Date d'inscription mardi 22 novembre 2016 Statut Membre Dernière intervention 6 juin 2022 - 19 sept. 2020 à 00:29
Raymond PENTIER Messages postés 56988 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 janvier 2023 - 19 sept. 2020 à 18:54
Bonsoir la communauté,

Je viens vers vous car je recherche la meilleure solution pour rechercher un nombre commun dans 3 colonnes ou 2 colonnes comme dans mon fichier joint. (https://mon-partage.fr/f/8un13Uys/)

J'ai utilisé la fonction RechercheV , qui fonctionne mais est ce la bonne fonction pour cela , car ensuite lorsque je veux extraire les nombres communs, je dois le faire manuellement, avec l'apparition des #N/A je n'arrive à renvoyer les doubles en (K4) ou les triples en (J4) dans le tableau.

J'espère avoir été la plus claire...

Merci d'avance
A voir également:

2 réponses

Raymond PENTIER Messages postés 56988 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 janvier 2023 17 172
19 sept. 2020 à 05:18
Bonsoir.

Oui, ce pourrait être la bonne fonction, mais à condition d'écrire la formule correctement ! Ainsi :
  • en F4 ce n'est pas =RECHERCHEV(B4;C4:C18;1;0) mais =RECHERCHEV(B4;C$4:C$16;1;0)
  • en G4 ce n'est pas =RECHERCHEV(C4;D4:D16;1;0) mais =RECHERCHEV(C4;D$4:D$16;1;0)
  • en H4 ce n'est pas =RECHERCHEV(B4;D4:D16;1;0) mais =RECHERCHEV(B4;D$4:D$16;1;0)
  • en J4 ce sera =SI(NB.SI($B$4:$B$16;B4)+NB.SI($C$4:$C$16;B4)+NB.SI($D$4:$D$16;B4)=3;B4;"")
  • en K4 ce sera =SI(NB.SI($B$4:$B$16;B4)+NB.SI($C$4:$C$16;B4)+NB.SI($D$4:$D$16;B4)=2;B4;"")
  • les formules en J4 et K4 sont à recopier jusqu'en ligne 16
  • les messages d'erreur #N/A n'ont aucune incidence sur ces calculs.
1
Valerie54001 Messages postés 130 Date d'inscription mardi 22 novembre 2016 Statut Membre Dernière intervention 6 juin 2022 1
19 sept. 2020 à 09:48
Merci Raymond !!!

les fameux $$ !!!
0
Raymond PENTIER Messages postés 56988 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 janvier 2023 17 172
19 sept. 2020 à 18:54
... et si toutefois tu souhaites ne pas voir ces vilains #N/A, il te faut compléter les formules ; en F4 tu remplaces
=RECHERCHEV(B4;C$4:C$16;1;0) par
=SIERREUR(RECHERCHEV(B4;C$4:C$16;1;0);"")
0