Demande formule Excel [Résolu]

Signaler
Messages postés
3
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
16 septembre 2020
-
Messages postés
3
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
16 septembre 2020
-
Bonjour,

Je souhaite connaitre quelle est la formule Excel pour savoir le nombre de pomme dans le local B ?
Ci-dessous le tableau.
Merci d’avance pour votre retour !

Site Légumes
local B poire
local B pomme
local C kiwi
local B kiwi
local A poire
local B kiwi
local D poire
local B pomme
local A kiwi
local A pomme
local C pomme
local A pomme
local D pomme
local D kiwi
local B pomme
local C kiwi
local A poire
local B poire

6 réponses

Messages postés
2437
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 septembre 2020
1 214
Bonjour,

Essayer avec cette formule:
=NB.SI.ENS(A:A;"Local B";B:B;"pomme")
Messages postés
12669
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 013
Bonjour

Avec une des formules de base d'Excel :
=NB.SI.ENS(A:A;"local B";B:B;"pomme")

Cdlmnt
Via
Messages postés
17227
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 septembre 2020
4 237
Bonjour,

j'imagine que dans ta colonne A tu as local B, local C etc et colonne B la liste des fruits

essaye cette formule
=SOMMEPROD((A2:A30="local B")*(B2:B30="pomme"))

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
3
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
16 septembre 2020

Bonjour,

Je viens d'essayer avec les 2 formules ci-dessous et le résultat me donne 0, alors que visuellement, on en compte 3.
=NB.SI.ENS(A:A;"local B";B:B;"pomme")
=SOMMEPROD((A2:A30="local B")*(B2:B30="pomme"))

Merci pour votre analyse et retour !
Messages postés
2437
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 septembre 2020
1 214
Les formules sont pourtant bonnes et fonctionnent correctement chez moi.

Vous avez pensé à adapter suivant vos besoins ( peut-être le nom des colonnes qui ne sont pas A ou B mais autre chose? )
Messages postés
12669
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 septembre 2020
2 013
C'est que ou local B ou pomme est écrit différemment dans ta base
souvent il y un espace invisible mis après le mot, à vérifier
si tu ne trouves pas l'erreur poste ton fichier sur cjoint.com, copie le lien créé et reviens le coller ici, on regardera
Messages postés
3
Date d'inscription
lundi 3 février 2020
Statut
Membre
Dernière intervention
16 septembre 2020

OK super les 2 formules fonctionnent !
C'était bien un problème d'espaces après le mot "pomme"

Merci bcp !!!