Analyse de la structure d'une adresse mail [Résolu]

Signaler
-
Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
-
Bonjour le forum,

Je n'arrive pas à trouver de réponse malgré mes recherches. Est-il possible via une macro ou formule d'analyser la structure d'une adresse mail. Je m'explique, je récupère des adresses mails, ça peut être **-*@*** ou ***@*** ou **.*@***.

J'ai trouvé avec les fonctions =SI(ESTNUM(CHERCHE comment avoir l'adresse après le @ mais je ne sais pas si il est possible de savoir si c'est un . un - ou attaché devant. Quelqu'un aurait une idée ?

Merci pour votre aide.

5 réponses

Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
effectivement, j'ai foiré sur une partie de la formule. Dans chaque groupe SIERREUR, le 2° TROUVE doit détecter @ et non pas le point où le tiret
fichier en retour avec B2et C2 selon demande, du moins je pense
(note pour C2: la proposition admet 25 caractères derrière l'arobase, modifiez le 25 si ce n'est pas suffisant)
https://mon-partage.fr/f/FnE3JeFA/
revenez si toujours des problèmes
crdlmnt

Messages postés
16549
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
9 759
Bonjour,

Qu'est ce que tu appelles "Analyser la structure" ?
Que veux-tu faire exactement à partir de ces adresses mail ?

Comment sont elles présentées ?

m@rina

Messages postés
23509
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
6 377
Bonjour à tous,

te donne la position du 1er point trouvé dans la partie gauche de l'adresse :
=SIERREUR(CHERCHE(".";GAUCHE(A2;CHERCHE("@";A2)-1));0)

0 si non trouvé
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Bonjour
une proposition pas très simple pour une adresse en A2, mais il doit y avoir plus simple
=SIERREUR(SIERREUR(SI(TROUVE("-";STXT(A2;1;TROUVE("-";A2)));"-");"")&SIERREUR(SI(TROUVE(".";STXT(A2;1;TROUVE(".";A2)));".");"");"")

traite la partie avant l'arobase, renvoie un pont si point, un tiret si tiret et rien si rien

crdlmnt
Le but est de recréer des adresses mails avec un nom et prénom ^^.

Merci pour ta formule Vaucluse. Elle fonctionne mais quand je remplace le . par un -, il m'affiche un -. . Je vous joins un fichier plus explicite :).

https://www.cjoint.com/c/JImsEI75Lq2

Merci encore pour votre aide.