Trouver si la valeur est présente dans la ligne d’un tableau. [Résolu]

Signaler
Messages postés
2
Date d'inscription
mercredi 2 septembre 2020
Statut
Membre
Dernière intervention
2 septembre 2020
-
Messages postés
2
Date d'inscription
mercredi 2 septembre 2020
Statut
Membre
Dernière intervention
2 septembre 2020
-


Bonjour,
Je vous expose mon problème et je sais que vous trouverez la solution que je n’ai pas trouvé.
Car trop débutant dans ce tableur.
Je veux avoir le résultat 1 ou 0 dans la colonne By si dans la ligne de la valeur Ay est présent la valeur de Ax précédente.
En B2 recherchée A1 dans la ligne du tableau correspondant à la valeur A2
Exemple :
ci dessus en B2 la valeur de A1 n’est pas présente dans la ligne de la valeur de A2
en effet la valeur 2(valeur de A1) n’existe pas dans E7:I7. ligne7 (valeur deA2),
par contre en B3 la valeur de A2 est bien présente dans la ligne de la valeur A3
en effet la valeur 7 (valeur de A2) est présente dans E11:I11. ligne 11 (valeur de A3)
etc.
J’ai essayé NB.SI trouver Ay correspondant à la ligne Az =
NB.SI(E7:I7;A2) =0
NB.SI(E11:I11;A3)=1
J’ai essayé RECHERCHEV(A2;E1:I12;2) mais ne prend que la valeur que la colonne 2 comme je peux avoir une vingtaine de valeur correspondant à chaque nombre cela deviens compliquer.
J’aurai au final colonne E :::1 à 40 et 20 valeur non trié dans la ligne correspondant
Un tableau de 40 (vertical) par 20 horizontal

Je ne sais pas si je me suis bien fait comprendre ….
Merci à tous



Configuration: Linux / Opera 70.0.3728.133

1 réponse

Messages postés
12566
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
3 septembre 2020
1 983
Bonjour Domy

=SI(NB.SI(INDIRECT("E"&A2&":I"&A2);A1)=1;1;0)

Cdlmnt
Via

Messages postés
2
Date d'inscription
mercredi 2 septembre 2020
Statut
Membre
Dernière intervention
2 septembre 2020

Woua ! ! ! ! super je ne connaissais pas la commande indirect et surtout comment passer la valeur d'une cellule en adressage de coordonné de cellule : les "E"&cellule etc...

Super ca marche

MERCI MERCI
je met résolu