Rapatrier lien hypertexte de la page 2 à la page 1 [Résolu]

Signaler
Messages postés
3
Date d'inscription
jeudi 16 juillet 2020
Statut
Membre
Dernière intervention
16 juillet 2020
-
Messages postés
1651
Date d'inscription
jeudi 13 mars 2003
Statut
Membre
Dernière intervention
30 octobre 2020
-
Bonsoir,

Je cherche une formule pour pouvoir rapatrier un lien hypertexte d'une feuille à une autre en fonction du numéro qui lui est attribué.

Par exemple: dans la page 2, le numéro "1" correspond au lien hypertexte "Test" et je voudrais que lorsque j'inscris le numéro "1" dans la page 1, le lien hypertexte s'affiche dans la cellule de la page 1 (B2)




J'ai essayé avec "=LIEN_HYPERTEXTE( " mais rien ne fonction et j'y comprends pas grand chose.

Merci pour votre aide.

:)

4 réponses

Messages postés
1651
Date d'inscription
jeudi 13 mars 2003
Statut
Membre
Dernière intervention
30 octobre 2020
278
Bonjour
A supposer que la feuille 2 contienne 2 colonnes de 20 lignes remplies de A2 à B20
Colonne A, des chiffres 1, 2, 3, etc
Colonne B, des liens titi.fr, toto.fr, tata.fr, etc...

en feuille 1, dans la cellule B2, saisir :
=SI(ESTVIDE(A2);"";RECHERCHEV(A2;Feuil2!$A$2:$B$20;2;VRAI))
Vous pouvez recopier vers le bas si remplissage de plusieurs saisies

On teste si saisie en A2, si non -> vide
Si oui, on recherche en vertical une correspondance feuille 2 de A2 à B20 et on affiche la colonne 2 que si c'est "exactement la même valeur" VRAI

A+


Si la réponse vous a aidé ou dépanné: un petit merci, si c'est résolu: cliquer le bouton vert en haut ;-)

Que celui qui n'a jamais ouvert un manuel utilisateur me jette la 1ère souris.
Messages postés
3
Date d'inscription
jeudi 16 juillet 2020
Statut
Membre
Dernière intervention
16 juillet 2020

Merci pour la réponse mais le lien ne suit pas, le mot "test" est bien écrit automatiquement mais sans le lien hypertexte.

Messages postés
1651
Date d'inscription
jeudi 13 mars 2003
Statut
Membre
Dernière intervention
30 octobre 2020
278
Bonjour
Oui, j'ai corrigé
=SI(ESTVIDE(A2);"";LIEN_HYPERTEXTE(RECHERCHEV(A2;Feuil2!$A$2:$B$20;2;VRAI);RECHERCHEV(A2;Feuil2!$A$2:$B$20;2;VRAI)))
Deux recherchev, la 1ère pour le Lien, la 2ème pour le nom du Lien
A+
Messages postés
3
Date d'inscription
jeudi 16 juillet 2020
Statut
Membre
Dernière intervention
16 juillet 2020

Bonsoir,

Super, ça fonction ! Merci beaucoup ! :)
Messages postés
1651
Date d'inscription
jeudi 13 mars 2003
Statut
Membre
Dernière intervention
30 octobre 2020
278
Bonjour
Alors c'est parfait.
A+