Mettre à jour une formule automatiquement (date du jour)

Signaler
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020
-
Messages postés
29122
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
9 juillet 2020
-
bonjour

je voudrais savoir svp, si c'est possible de mettre à jour une formule sous excel par rapport à la date du jour?

au niveau de la cellule A10 j'ai une formule qui calcule une moyenne, =SOMME(B10:P10)/SOMME(B10:AM10).
je voudrais que demain quant j'ouvrirai mon fichier la formule sera remplacer par =SOMME(B10:Q10)/SOMME(B10:AM10), c'est à dire inclure le jour suivant dans la MOYENNE

je vous remercie d'avance

https://www.cjoint.com/c/JFElY0wOUFG

2 réponses

Messages postés
642
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 juillet 2020
63
Bonjour,

inscrire =AUJOURDHUI() dans Z1 par exemple et ensuite :

=SI($Z$1=AUJOURDHUI();SOMME(B10:Q10)/SOMME(B10:AM10);"")
Messages postés
29122
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
9 juillet 2020
6 492
Bonjour,

en A10 :
=SOMME(B10:INDIRECT(ADRESSE(10;EQUIV(AUJOURDHUI();B7:AM7;0)+1;1)))/SOMME(B10:AM10)