Nombre de chiffres après la virgule sur la feuille de calcul.

Signaler
-
Messages postés
51862
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
-
Bonjour,



Configuration: Windows / Chrome 83.0.4103.116

Je voudrais savoir comment je peux limiter le nombre de chiffres après la virgule sur un feuille de calcul dans excel. De telle sorte que en cliquant sur la cellule en question, les chiffres supprimés n'apparaissent pas de nouveau.

2 réponses

Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Bonjour,

Sous réserve d'avoir compris la demande, sélectionner la plage à traiter/clic droit sur la sélection/Format de cellule/onglet Nombre/Nombre/Nombre de décimales
Messages postés
51862
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
13 580
Bonjour Alain-Rollon.
Bonjour Mike-31.

Si en A1 tu saisis la valeur 1,1234567 et tu valides ta saisie, c'est elle qui reste en mémoire de l'ordinateur.
- Tu peux diminuer la largeur de la colonne pour afficher moins de décimales.
- Tu peux, comme indiqué par Mike-31, changer le format d'affichage à l'écran.

Mais quand tu cliques sur A1, tu as toujours la saisie initiale dans la barre de formule ; et si en A2 tu mets la formule =A1*1000 elle donnera comme résultat 1123,4567 ...
Il faut arrondir ta valeur.
Donc si cette valeur en A1 est le résultat de l'opération =B9/3 avec B9=3,370370367 il te faut modifier la formule.
Pour cela, ajouter la fonction ARRONDI et écrire =ARRONDI(B9/3;2) qui donne comme résultat, aussi bien en affichage-cellule qu'en mémoire-machine, le nombre 1,12 ...

Cordialement.