Clé USB SanDisk non détectée menu de démarrage

Signaler
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020
-
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
-
Bonjour,

J'ai récemment recu un nouvelle clé USB SanDisk 32Go que je souhaite utiliser en tant que Linux live. Je possède déjà une autre clé SanDisk de 16go avec un autre Linux, aussi en Live, qui marche très bien depuis maintenant un an.
Après avoir flashé l'ISO sur ma nouvelle clé, je la branche dans mon ordinateur portable et la surprise lorsque je rentre dans le menu de démarrage : aucune entrée n'est détéctée, pas même Windows !(et curieusement si je clique sur "continuer l'amorcage par défaut" Windows démarre quand meme). J'ai essayé avec une autre distribution Linux, même résultat.

J'ai aussi essayé sur mon autre pc fixe, cette fois les entrées de démarrage windows s'affichent quand meme mais toujours pas de clé USB en vue.

Voici la clé que j'ai acheté : https://www.fnac.com/Cle-Double-Connectique-USB-Type-C-Sandisk-Ultra-Dual-Drive-32-Go/a12688498/w-4#omnsearchpos=7

Enfin, j'ai essayé avec une dernière clé SanDisk (https://www.ldlc.com/fiche/PB00152003.html) , qui elle n'a jamais servi en tant que disque de démarrage mais rien à faire...

Pourquoi ces 2 clés ne marchent pas ? Pourquoi sur mon pc portable il ne détecte plus aucune entrée de démarrage quand je les branche ?

En résumé : que se passe-t-il ? :(

Merci d'avance pour votre aide

11 réponses

Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Bonjour,

Regarde dans le BIOS si ta clé est reconnue... comme un disque..? (dans le BIOS, pas dans windows)

--- Tu dois parametrer ton Bios en "Boot Device" pour qu'il boot en premier sur ta clé USB...
-- Ta clé et l'ISO qu'elle contient ne doit pas etre conforme aux exigences réclamées par le PC. Par exemple Boot UEFI ... ou elle n'est pas crée avec Rufus par ex...

--- Le formatage est en EXTx, tu ne risque pas de le voir sous windows..
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Je ne veux pas que la clé soit le premier disk a booter puisque mon système principal reste Windows. Cette clé me sert simplement de temps en temps quand j'ai besoin d'une plateforme Linux.

J'ai bel et bien flahsé l'IOS a l'aide de rufus et en mode UEFI

Je ne voit pas le rapport avec l'EXT4... Je n'utilise pas cette clé dans Windows donc aucun souci la dessus

Et encore une fois mon autre clé marche très bien donc je pensais que c'était peut etre lié aux composants de la nouvelle clé (qui marche cependant pour les transferts de fichiers)..
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739
Bonjour,

J'ai fait récemment une clé bootable avec une distribution Linux.
J'ai utilisé Rufus.
La clé est en FAT32.
Tout fonctionne parfaitement.

Vous pouvez très bien configurer le BIOS pour que l'ordinateur boote en premier sur la clé USB.
Vous ne verrez aucun ralentissement pour booter sur Windows, si la clé n'est pas présente.

J'ajoute que ma clé est reconnue dans la gestion des disques (Ce PC > Gérer > Stockage).

Si vous avez fait cette clé pour utiliser LINUX, je vous conseille plutôt de faire une machine virtuelle avec VirtualBox. C'est un peu pénible à faire si on n'a pas l'habitude. (Il y a beaucoup de tutos). Vous n'aurez pas à refaire le paramétrage complet (langue + clavier) à chaque utilisation.
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739 >
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Il n'y a a pas besoin qu'une clé soit insérée.

Par contre, ce n'est pas toujours très clair dans le BIOS.
Pour moi il faut sélectionner USB diskette on Key/USB Hard Disk et le faire remonter en première position.
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739 >
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020

photo de l'écran du BIOS :

C'est fait sans qu'aucune clé USB ne soit insérée.
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020
>
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020

Excusez moi je n'avais pas vu cette option. ET bien même après avoir fait ca Windows boot meme si la clé est branchée
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052 >
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Si la clé n'existe pas dans le BIOS parmi le matériel reconnu, comme les disques par ex... Elle est mauvaise, comme si c'était une clé en bois... elle ne pourra jamais booter, il faut la faire changer par le vendeur...

Par contre elle doit etre mauvaise sur tous les PC, si elle est vraiment mauvaise..

Comme le dit @Pierre10, placer le boot device sur USB en premier n'empêche pas de démarrer en Windows... Qui est, lui, sur le disque dur... À condition que cette clé USB bootable ne soit pas branchée...
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020
>
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020

Elle marche parfaitement bien lorsque je l'utilise comme tout le monde utilise une clé usb : pour stocker des fichiers : les débits sont les mêmes que ceux annoncés, l'USB 3.0.. tout marche très bien du moins quand je ne l'utilise pas en tant que clé USb bootable
Messages postés
1400
Date d'inscription
lundi 17 février 2020
Statut
Membre
Dernière intervention
3 juillet 2020
73
salut, peut tu envoyer une capture d'écran du gestionnaire de disque ?
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Messages postés
1400
Date d'inscription
lundi 17 février 2020
Statut
Membre
Dernière intervention
3 juillet 2020
73 >
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

ok, tape disk part dans le raccourci windows +r, ensuite tape list disk, et select disk 4, puis tu tape list partition et tu fait delete partition 1,2,3,4 et ensuite tape select disk 4 puis clean et dit moi si ca marche
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020
>
Messages postés
1400
Date d'inscription
lundi 17 février 2020
Statut
Membre
Dernière intervention
3 juillet 2020

Oui toutes les partitions ont été effacées.
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Selon le matériel, certain ne boot qu'en USB2... Même si ça fonctionne en USB3 pour les échanges de fichiers... il faut donc se méfier de cette option pour du BOOTABLE..

Si cette clé fonctionne bien par ailleurs... Elle est bonne... donc la raison est ailleurs.

--- Et ailleurs, c'est l'installation du fichier ISO dans la Clé..

Soit l'ISO n'est pas bon ou ne convient pas à ce PC...?
Soit le montage / gravure n'est pas fait comme il le faudrait...

Au fait, c'est quoi la marque et le modèle de ce PC..??
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

L'autre clé est UBS3 et boot très bien donc je ne pense pas que ce soit le problème.

Pour ce qui est de l'ISO, j'ai essayé le même sur mon autre clé qui marche et tout fonctionne à merveille

Pour le pc je fais les tests sur deux PC : mon PC pro (HP ProBook x360) et mon PC perso qui est une configuration que j'ai montée mais globalement carte mère ASRock et Ryzen 5
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739
Il y a quelque chose qui ne va pas dans la structure de votre clé. Voilà ce que j'ai :

Et rien de plus !

Je vous conseille de recommencer, toujours en utilisant Rufus. Vous pouvez la formater avant.
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Ah oui non c'est juste car cette fois j'ai flashé la clé autrement mais même avec rufus mon ordi refuse de la détécter
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

Alors

J'ai trouvé une ""solution"" mais qui ne marche que sur mon pc portable. Lorsque je vais dans le boot menu, j'ai une option "démarrer a partir du fichier" qui nous sert a donc a aller chercher manuellement le fichier efi pour démarrer.

Ma solution coniste donc a aller dans le boot menu, brancher la clé, cliquer sur démarrer a partir du fichier et la surprise : lorsqu'il me demande de choisir le disque sur lequel se trouve le fichier EFi ma clé aparait ! Je peux donc aller dans /EFI/BOOT et lancer BOOTx64.efi et tout mon système démarre alors.

Ma clé USB est donc détectée est lisible par le BIOS

J'ai cette solution, après je vous avoue qu'elle est très peu pratique. Si vous avez une idée de pourquoi elle ne s"affiche toujours pas dans le boot menu, toute aide est la bienvenue
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739
"Peu pratique" : C'est le moins que l'on peut dire.

Je branche la clé, je redémarre l'ordinateur et ça boote sur la clé !
C'est comme ça que ça doit se passer.
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Mais si elle est détecté... elle doit etre affichée aussi dans le BIOS...
On ne peut pas dire=== Détecté et pas affiché...

Vu ce que tu dis au sujet du fichier EFI.... Ce problème est un problème de boot en UEFI..

Ce PC là doit etre en UEFI et pas les autres... ça doit etre une histoire de ce genre.
Messages postés
4588
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
3 juillet 2020
1 739
Je ne pense pas que ce soit ça.

J'ai 2 ordis, un vieux Dell et un HP en UEFI. La clé que j'ai réalisée fonctionne sans problème sur les 2 ordinateurs.

Je viens de la refaire sur le HP. Je suis parti d'une clé formatée en FAT32 (clé Sandisk ultra USB3). J'ai fait le truc sans me poser de questions et en suivant les options et les suggestions de Rufus. J'ai choisi le mode de partition MBR.
Même résultat : j'obtiens une clé bootable et qui fonctionne sur tous mes ordis.

J'ai également fait un essai avec le mode de partition GPT : Sans surprise la clé fonctionne sur l'ordinateur en UEFI, mais pas sur le vieux Dell.

C'est vraiment incompréhensible.
Euh si si les 2 PC sont bien en UEFI
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Tout ça est bien étrange... moi aussi je fais des boot USB et aussi DVD, tous mes boot device sont en
1° CD/DVD
2° USB
3° HDD
Et effectivement, je n'ai pas de difficultés aux démarrages, quel que soit le PC... des vieux et des Bien modernes à base de Ryzen 7 par ex...

Je suppose qu'il y a quelque chose d'autre de tordu, là dessous... J'ai une pensée pour cette clé USB qui est particulière... elle a le double connecteur USB... un USB A et un USB C avec une vitesse de transfert annoncée assez élevée (150m) on ne dit pas si c'est en écriture ou en lecture..?? et aussi pour une 32 Go, il n'y a que 28 de dispo... Donc il y a là dedans un firmware d'environ 4 Go (ce n'est pas un peu) qui est dédié par le fabricant pour satisfaire les prestations de cette clé... N'y aurait-il pas un conflit là dedans

Il y a un contexte de conditions réunies entre cette clé, le BIOS du PC et le boot installé...

Ma suggestion serait de tenter la même manip avec une autre clé USB... très lambda... en USB2 de super marché ... disons classe 10 quand même pour ne pas etre trop lente... et au moins 8Go.

Voila une autre façon.. de tenter.
Bon alos j'ai essayé avec une très vieille clé et tout boot parfaitement sur les 2 PC. Pour ce qui est du connecteur USB C et A je ne pense pas que ce soit le problème car mon autre clé USB qui ne marche pas n' a qu'un seul connecteur usb A.

Pour ce qui est des vitesses je ne vois pas ce qu'il y a de bizare. 150MO/s c'est en lecture. En écriture elle est a environ 50Mo/s

Pour ce qui est de l'espace de la clé non ce n'est pas le firmware qui fait 4go (et heureusement) c'est simplement que SanDisk ne compte pas un 1go de la même manière que les OS.
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Si tu le dis... je veux bien... mais c'est quand même étrange de tels comportement machine, il y a un truc...

Pour le comptage des octets différents chez SanDisk, je reste perplexe... Un octet, c'est huit bits partout dans le monde... On peut ajouter que SanDisk fait ses clés avec des composants mémoires fabriqués et vendus par des constructeurs de chip mémoire ou tout l'adressage est parfaitement organisé sur ces mêmes calculs impossible à inventer, c'est la loi du combinatoire ou des tables de Karnauhg... 1Go, est en fait 1024 donc un peu plus...et ici, ce serait un peu moins..

-- Par ailleurs, j'aimerais etre petite souris dans ton PC... car bien souvent les grandes vitesses et l'USB3 ne fonctionnent effectivement à ces vitesses que sous windows... Alors que ici, il s'agit de Booter, il n'y a pas de windows en place... c'est le BIOS qui pilote le fonctionnement de la clé USB... bon nombre de PC démarrent en USB1 sous le BIOS... et aussi beaucoup en USB2... Mais ceux qui sont en USB3 depuis le BIOS sont beaucoup plus rares... ce n'est pas systématique, même sur les modèles récents... J'ajouterai que bien souvent, c'est à moitié faux, pour le débit; il faut tester sur du matériel avec des mesures.

En transfert de Datas sous windows, ça fonctionne bien, mais pour booter c'est une autre affaire.
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020



Et bien non justement. Moi aussi j'étais scotché quand j'ai appris que 1go en fait ce n'est pas une taille fixe. Mais si si c'est bien le cas et c'est même écrit maintenant pour éviter les surprises des utilisateurs derrière les boîtes des Sandisk

Effectivement peut être que certains PC supportent mal l'USB3 au boot mais encore une fois j'ai une autre clé Sandisk de 16go en usb3 type A qui marche parfaitement bien sûr mes 2 ordinateurs. Et elle utilise bien l'USB3 et ne se "downgrade" pas en USB2 toute seule
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
Voila le texte explicatif de SanDisk https://kb.sandisk.com/app/answers/detail/a_id/46/~/capacity-of-the-device-%28as-reported-by-many-operating-systems%29-does-not-match

Ou je suis d'accord... il faut bien saisir qu'il disent 1Go par commodité de langage
"SanDisk defines 1 GB as 1,000,000,000 bytes" (SanDisk defini 1 GB comme 1,000,000,000 d'octets Alors que le System compte 1,073,741,824 OCTETS)

Il faut savoir que ces valeurs sont "Non formaté" et après formatage il n'y a plus que 950 mega environ de disponible pour l'utilisateur car les marques et repères du formatage utilisent un peu de place... et je trouve que ta clé en utilise un peu de trop... il doit y avoir quelque chose de plus qui a été introduit par SanDisk, qui occupe le début de ta clé et l'empêche de booter...Ton fichier doit etre dès le début de la zone mémoire et je crois que ce n'est pas ton cas...

-- Pour ça, je te propose de formater ta clé avec le logiciel "SDcard Formatter" en Fat32 https://sd-card-formatter.fr.uptodown.com/windows
Son formatage est différent de celui de windows qui est en "exFAT32"

ensuite tu installe à nouveau ton ISO et retente l'opération... que tu connais bien maintenant.

Pour le downgrade ou pas de tes autres PC, je n'en sais rien... il faudrait déja voir ce qui est écrit dans le BIOS..?? et aussi une clé USB3 en USB2... la différence sous BIOS n'est pas évidente.
Messages postés
28
Date d'inscription
mercredi 6 novembre 2019
Statut
Membre
Dernière intervention
2 juillet 2020

J'ai essayé ton logiciel et j'ai bien formaté la clé mais elle a toujours 28.95Gb libres mais encore une fois cela me paraît tout à fait logique car
32 / 1.073... = 29.80Gb libres pour Windows. Si tu enlève les 900mb du formatage tu trouve 28.90 ce qui confirme donc les 28.85GB indiqués par le gestionnaire de disque.

Et puis j'ai déjà de nombreuses fois même supprimé toutes les partitions de ma clé donc non il n'y a rien que SanDisk a pu rajouter et qui empêche le boot

Pour ce qui est di downgrade je te confirme bien qu'elle est utilisée en USB3 par le BIOS donc aucun problème a ce niveau là
Messages postés
17908
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
3 juillet 2020
3 052
OK, j'en ai une aussi comme ça, elle fait 29.79GB... Donc on est d'accord.
Par contre autant pour moi, elle est formaté en NTFS et pas en FAT32... à essayer..
Car je continue de croire fortement que c'est la clé USB qui est coupable..