2 formules

Signaler
-
Messages postés
643
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
10 juillet 2020
-
Bonjour,

voici mon problème :
colonne Q : valeur en %
colonne R : OUI ou NON

Si la colonne R = OUI alors je veux le nombre de cellule de la colonne P avec une valeur en 0 et strictement < à 55%

merci !!

Configuration: Windows / Firefox 68.0

5 réponses

Messages postés
2216
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
3 juillet 2020
1 103
Bonjour,


Formule à écrire en P je dirais:
=Si(R1="OUI";*Faite ce que vous voulez faire car j'ai pas trop compris vos explications* ; "")
Messages postés
643
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
10 juillet 2020
63
Bonjour,

si j'ai bien compris car c'est pas évident :

=SI(ET(R2="OUI";Q2<55%);P2;"")
Effectivement j’ai du mal à m’exprimer.
Dans la colonne R j’ai que des oui et des non.
Dans la colonne Q j’ai des valeurs en %. Exemple :
Q R
10% Oui
30% Oui
30% non
54 % Oui
10% Non
70% Oui

Si R = oui
Alors combien ai je de valeur strictement inf à 55%
Messages postés
643
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
10 juillet 2020
63
=SOMMEPROD((R2:R50="OUI")*(Q2:Q50<55%))

Plage de données des matrices à adapter.
Tant que j'y suis, j'en profite pour poser une autre question.
J'ai récupéré un fichier excel déjà construit. partout ou il y a des formules, elles ne se mettent pas à jour automatiquement.
Obligé de doublé cliquer puis faire "enter" pour qu'elles se mettent à jour.
Une idée?
Messages postés
643
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
10 juillet 2020
63 > Ce38
Sans doute que l'option de calcul des formules n'est pas sur "automatique" !
Merci beaucoup !!