Formule [Résolu]

Signaler
-
 fred -
Bonjour Michel

Ma demande est du même principe que ma premier question.
J'ai besion d'une formule comment prècèdement

Si B2 indique 1er C2 Doit indiqué 1
2ème = 2
3ème = 3
Jusque 10
11 et plus = 0
Le chiffre que je demande met très utile pour obtenir une valeur
Actuellement je le fais manuellement, mes cela comporte des risques d'erreur
Je t'en remercie d'avance
Fred

5 réponses

Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
Bonjour,

essaye comme cela
=SI(SUBSTITUE(SUBSTITUE(B2;"er";"");"ème";"")*1<=10;SUBSTITUE(SUBSTITUE(B2;"er";"");"ème";"")*1;0)
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
Re,

Comment elle ne fonctionne pas, après l'avoir collée sur ton fichier en cellule AH2 et incrémentée vers le bas j'ai bien le résultat attendu NON !

=SI(SUBSTITUE(SUBSTITUE(AI2;"er";"");"ème";"")*1<=10;SUBSTITUE(SUBSTITUE(AI2;"er";"");"ème";"")*1;0) 


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
super Mike
Je viens de réesayé et sa fonctionne
Je te remercie
Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 128
Re,

lorsque je donne une formule d'après ce que je comprends, je fais en sorte de la tester avant

je passe le statut de la discussion en résolu
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Oui j' réesayé avec la formule que tu as rectifier et sa fonctionne
Tu est Génial
un tous grand merci
Fred
Messages postés
643
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
10 juillet 2020
64
Bonjour,

En C2 et à tirer vers le bas :

=SI(B2="1er";1;SI(B2="2ème";2;SI(B2="3ème";3;SI(B2="4ème";4;SI(B2="5ème";5;SI(B2="6ème";6;SI(B2="7ème";7;SI(B2="8ème";8;SI(B2="9ème";9;SI(B2="10ème";10;0))))))))))
https://www.cjoint.com/c/JFymDCuLt5G
La formule ne fonctionne pas ;)
Je vous joint le fichier, pour que l'on puis voir plus clair
dans l'exemple que j'ai donné, J'ai utilisé La colonne b ligne 2
en faite la formule doit etre mis dans la colonne AH et prendre l'info de la colonne AI. de la feuil encodage
Désolé Mike
la formule que tu ma donné ne fonctionne pas ;)
Merci quand mëme