Compter le nombre de cellule de couleur [Résolu]

Signaler
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020
-
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
-
Bonsoir à tous,

J'aimerais avoir une cellule qui compte le nombre de cellule passé en orange, est-ce possible ?
Tout en sachant que les cellules orange peuvent être, selon la valeur à l'interieur, être de couleur vert ou rouge.

M'avez-vous compris ? Avez-vous une solution ?

Merci à tous.


Configuration: Windows / Firefox 76.0

10 réponses

Messages postés
12777
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 octobre 2020
2 043
Bonsoir

Les cellules sont corrigées manuellement ou sont elles issues d'une MFC?
Il serait bon de joindre ton fichier en le postant sur cjoint.com, en copiant le lien créé et en revenant le coller ici
Cdlmnt
Via
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Bonsoir,

tu parles de trois couleurs vert, rouge et orange, comment ces cellules sont colorisées: manuellement ou automatiquement avec une mise en forme conditionnelle. si c'est le cas que est la formule conditionnelle pour coloriser en orange
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

Oui elle sont issues d'une MFC, si la valeur est inférieur 11:00 elle deviens orange, si elle est supérieur ou égale à 11:00 elle est vert et enfin, inférieur à 9:00 elle devient rouge.

Dans les cas de rouge et orange, j'aimerais qu'une cellule informe le nombre de cellule qui a ces couleurs.
Peut-être que la meilleur des solutions serait plutôt de compter le nombre de cellule inférieur à 11:00 puisqu’au finale c'est ce que je cherche à faire .... qu'en tu ? et qu'elle serait la formule ?

Merci de ton aide. Je vois pour te mettre le fichier.
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

Voici le lien : https://www.cjoint.com/c/JEFtZ4sJ1Yn

Merci pour votre aide.
Les cellules ou doit se trouver le comptage sont en pied de page.

Je vous conseil de zoomer et dézoomer pour remettre les chose en place (petit bogue).
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Re,

Quel est la formule utilisée pour ta mise en forme conditionnelle qui gère la couleur orange pour connaitre les cellules contrôlées
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Re,

en gardant tes valeurs

=SOMMEPROD((F10:AG10>=0,375)*(F10:AG10<=0,45763889)*(F10:AG10<>""))

mais pour ma part je l'écrirais

=SOMMEPROD((F10:AG10>="09:00"*1)*(F10:AG10<="11:00"*1)*(F10:AG10<>""))

mais il est possible de l'écrire encore différemment, plus simplement comme cela

=SOMMEPROD((F10:AG10>="09:00"*1)*(F10:AG10<="11:00"*1))


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

Merci beaucoup, ça fonctionne au poile,
mille merci ;).
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

Et si je veut la même formule, mais cette fois-ci compter le nombre de cellule qui affiche plus de 09:00 mais UNIQUEMENT pour les cellules suivantes : G25;K25;O25;S25;W25;AA25;AE25

Qu'elle serait la formule STP ?
Merci de ton aide.

Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

J'ai essayé avec cette formule (ci-dessous) cela fonctionne, mais ça me prend toutes les cellules de la ligne, hors je souhaite vérifier l'information uniquement dans les cellules suivantes : G25;K25;O25;S25;W25;AA25;AE25 et non de G25 à AE25

=SOMMEPROD((G25:AE25>="09:01"*1)*(G25:AE25<>""))

Comment faire comprendre à Excel que je souhaite vérifier l'information dans des cellules spécifique ?

Merci pour votre aide,
Bonne fin de journée.

Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Re,

ce n'est pas la même démarche, regarde comme cela, fait attention aux signe {}

=SOMME(NB.SI(INDIRECT({"G25";"K25";"O25";"S25";"W25";"AA25";"AE25"});">=10:00"))

une petite astuce pour tester les parties de formule, exemple pour tester cette partie qui est la partie maîtresse, de la formule, sélectionne dans la formule cette partie etclic sur la touche fonction F9
INDIRECT({"G25";"K25";"O25";"S25";"W25";"AA25";"AE25"})

cela va t'afficher
{0,451388888888889;0,120138888888889;0,263888888888889;0,439583333333333;0,236805555555556;0;0}
en fait le résultat est la valeur heure affiché en décimal reste plus avec la syntaxe NB.SI compter les valeurs supérieures ou égales à 10:00 c'est à dire 0,416666666666667

attention si tu utilises ce test de ne pas oublier de sortir de la fonction avec Echap et surtout pas Entrée

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
98
Date d'inscription
mercredi 6 mai 2020
Statut
Membre
Dernière intervention
20 septembre 2020

Super !!! merci à toi, ça fonctionne bien !
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Re,

garde en mémoire la façon de tester une formule, voir la tester par module.

Je passe le statut de la discussion en résolu