Echec écriture sur partition NTFS [Résolu]

Signaler
Messages postés
948
Date d'inscription
dimanche 17 octobre 2004
Statut
Membre
Dernière intervention
20 octobre 2020
-
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
-
Bonjour à tous,

Je viens d'installer kubuntu 20.04 LTS en dual boot avec Windows 10. Au préalable j'ai fait un backup de toute mes données Windows sur mon Hdd externe formaté en ext4 et maintenant j'ai besoin de pouvoir écrire sur ma partition windows (donc ntfs) afin de restaurer ces données mais ça ne marche pas car la partition est montée en lecture seule. J'ai installé 2 ou 3 programmes dont fuse mais rien. Par contre, j'arrive à écrire sans problème sur ma clé USB de 16 Gio formatée en ntfs. Avant, sur kubuntu 18.04, il me suffisait de cliquer sur ma partition Windows et j'arrivais à écrire sans soucis.
J'ai comparer les droits entre ma clé et ma partition windows et ils sont exactement pareil.
S'il vous plaît comment régler ce problème super embêtant.

Merci de m'avoir lu.


Si quelqu'un fait quelque chose de bien, imite le. Et lorsque quelqu'un
fait quelque chose de mal, cherche en toi en quoi tu l'imites.(Confucius)

2 réponses

Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 969
Bonjour,

Vérifie comment est montée ta partition windows. En particulier il faut qu'elle soit montée en
rw
. Par le passé il fallait en plus que ton utilisateur soit dans le groupe fuse.

Exemple : dans mon cas, la partition windows est montée dans
/media/windows
, je peux donc afficher ses propriétés avec la commande
mount | grep windows
.
(mando@silk) (~) $ mount | grep windows
/dev/sda3 on /media/windows type fuseblk (ro,relatime,user_id=0,group_id=0,allow_other,blksize=4096)


On voit qu'elle est montée en ro (read only), donc je ne peux en aucun cas écrire dessus, y compris en root.

(mando@silk) (/media/windows) $ sudo touch toto
[sudo] Mot de passe de mando :
touch: impossible de faire un touch 'toto': Système de fichiers accessible en lecture seulement


Pour corriger ça, il faudrait corriger les options de montage, idéalement dans
/etc/fstab
(ce qui permet de sous-entendre les paramètres à passer à la commande
mount
), et remonter
/media/windows
. Dans mon cas, la ligne concernée est celle qui correspond au résultat de
grep windows /etc/fstab
puisque mon point de montage est
/mnt/windows
.

Exemple : Dans mon cas j'obtiens :

UUID=42C8949DC89490B1                           /media/windows  ntfs    ro              0       0


Il faut donc corriger cette ligne (e.g. avec
pkexec gedit /etc/fstab &
) en changeant ro par rw (conformément aux explications données dans
man mount
). Il ne faut pas changer l'UUID chez toi qui dépend de ton installation. Si tu changes le point de montage, il faut créer le répertoire vide correspondant au préalable (
sudo mkdir -p /media/windows
).

Ensuite :

sudo umount /media/windows
sudo mount /media/windows
mount | grep windows


La dernière commande sert juste à contrôler que les changements ont été pris en compte.

De la même manière, il faudrait corriger probablement l'UID associé à ce
mount
afin de ne pas avoir besoin de
sudo
pour avoir les droits en écriture sur ladite partition. Il faut récupérer au préalable l'UID de ton utilisateur :

Exemple :

(mando@silk) (~) $ echo $UID
1000


La ligne de
/etc/fstab
deviendrait, dans mon cas :

UUID=42C8949DC89490B1                           /media/windows  ntfs    rw,uid=1000              0       0


Pour prendre en compte les changements :

sudo umount /media/windows
sudo mount /media/windows
mount | grep windows


Bonne chance
Messages postés
948
Date d'inscription
dimanche 17 octobre 2004
Statut
Membre
Dernière intervention
20 octobre 2020
45
Merci pour ce partage très riche mais il semble que le problème était plus simple. Il a suffit que je démarre W10, puis que je choisisse "redémarrer" pour aller sous linux au lieu de choisir "arrêt". Et une fois sous linux, j'ai pu sans problème écrire sur la partition.
Depuis longtemps (sur des précédentes version de kubuntu), quand je voulais aller sous linux, je faisais "arrêt" parce que lorsque je faisais "redémarrer" je n'avais plus de son sous linux. Là j'ai fait "redémarrer" et je peux écrire avec le son toujours fonctionnel. Encore merci pour ton sens du partage, mamiemando.
Ouf.
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 969
Ah effectivement, j'ai oublié ce point : selon la manière dont tu quittes windows, le système de fichiers (ta partition ntfs) peut être en état d'hibernation, et un redémarrage sous windows est alors nécessaire. Généralement, quand tu tentes de créer / modifier un fichier depuis le terminal, un message d'erreur l'indique en toutes lettres.

Plus de détails ici.

Merci pour ton retour et bonne continuation