Formule à plusieurs conditions: Erreur Valeur

Résolu/Fermé
Noem794 Messages postés 6 Date d'inscription lundi 18 mai 2020 Statut Membre Dernière intervention 19 mai 2020 - 19 mai 2020 à 07:41
Noem794 Messages postés 6 Date d'inscription lundi 18 mai 2020 Statut Membre Dernière intervention 19 mai 2020 - 19 mai 2020 à 08:11
Bonjour à tous,

J'ai à nouveau besoin de vos lumières... Je cherche à effectuer un calcul excel à plusieurs conditions.

J'ai une cellule A1 dans laquelle je rentre des données à la main et aimerais qu'en cellule B1 le calcul se fasse sous ses conditions:
- Si A1 est compris entre 0 et 1000 (incluant les valeurs limite) alors B1=A1*0,6
- Si A1 est compris entre 1001 et 2000 (incluant les valeurs limite) alors B1=A1*0,7
- Si A1 est compris entre 2001 et 3000 (incluant les valeurs limite) alors B1=A1*0,8
- Si A1 est compris entre 3001 et 4000 (incluant les valeurs limite) alors B1=A1*0,9
- Si A1 est supérieur à 4000 (N'incluant PAS les valeurs limite) alors B1=A1

J'ai essayé la formule suivante dans la cellule B1 mais ça ne marche pas et me met une erreur #VALEUR:
=SI(A1<=1000;A1*0,6;SI(A1<=2000;A1*0,7;SI(A1<=3000;A1*0,8;SI(A1<=4000;A1*0,9;SI(A1<4000;A1)))))

Pour info, j'ai simplifié pour que ce soit plus clair pour vous, mais les valeurs limite sont en fait chacune le résultat d'autres calculs réalisés dans les cellules d'un autre onglet... Je ne sais pas si ça peut avoir une incidence...

Auriez-vous une solution à mon problème?

Merci par avance!

3 réponses

M-12 Messages postés 1313 Date d'inscription lundi 22 septembre 2008 Statut Membre Dernière intervention 25 janvier 2023 289
19 mai 2020 à 07:55
Bonjour,
il y a une erreur sur le calcul pour la valeur Sup. à 4000 (inversion du signe)
=SI(A1<=1000;A1*0,6;SI(A1<=2000;A1*0,7;SI(A1<=3000;A1*0,8;SI(A1<=4000;A1*0,9;SI(A1>4000;A1)))))
0
Noem794 Messages postés 6 Date d'inscription lundi 18 mai 2020 Statut Membre Dernière intervention 19 mai 2020
19 mai 2020 à 08:05
Merci beaucoup!
Effectivement! J'ai modifié ce détail de la formule...
Pour autant, ça ne marche toujours pas... Auriez vous une autre formule à me proposer?
0
Noem794 Messages postés 6 Date d'inscription lundi 18 mai 2020 Statut Membre Dernière intervention 19 mai 2020
19 mai 2020 à 08:11
Et bien écoutez, après nouvel essai en repartant de zéro, finalement ça fonctionne!
Merci infiniment!
Et bonne journée...
0