Relancer formule si cellules identiques [Résolu]

Signaler
Messages postés
3
Date d'inscription
mardi 5 mai 2020
Statut
Membre
Dernière intervention
5 mai 2020
-
Messages postés
3
Date d'inscription
mardi 5 mai 2020
Statut
Membre
Dernière intervention
5 mai 2020
-
Bonjour,

J'aimerais créer sur excel une sorte de machine me permettant d'obtenir 3 noms extrait d'une liste, de manière aléatoire.
Afin de générer des noms aléatoirement dans 3 cellules différentes, j'ai utilisé cette formule qui marche très bien ;
=CHOISIR(ENT(ALEA()*8)+1;"PAUL";"PIERRE";"HUGO";"JEAN";"DAVID";"NINO";"AMAL";"MANU")

Cependant, j'aimerai que les 3 cellules ne puissent pas m'afficher des noms identiques, ce qui arrive parfois, une sorte de formule pour "relancer" la sélection aléatoire si la cellule A1 = A2 et si A2 = A3.

Merci d'avance pour votre aide

2 réponses

Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
860
Bonsoir
une proposition
en A2
=RECHERCHEV(PETITE.VALEUR($D$2:$D$9;LIGNE()-1);$D$2:$E$9;2;0)


Messages postés
3
Date d'inscription
mardi 5 mai 2020
Statut
Membre
Dernière intervention
5 mai 2020

Bonsoir !
Merci pour votre réponse
J'ai suivi votre raisonnement concernant le tirage mais je bloque sur la formule de ma 3eme cellule (la A4 sur votre image), j'ai appliqué la sélection du plus petit nombre en aléatoire pour une cellule, et du plus grand pour l'autre, mais je ne comprend pas comment faire avec la 3eme ?


De plus j'aimerai intégrer un bouton me permettant de relancer a chaque clique la machine, avais vous une idée de comment procéder ? Ou du moins de la formule vba à intégrer peut être

Merci encore
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
860
Bonsoir
remplacer ligne()-1
par :
1 en E6
2 en F6
3 en G6

Pour relancer le tirage, a priori touche F9 ou enregistrer une macro en faisant F9 et associer la macro à un bouton
Messages postés
3
Date d'inscription
mardi 5 mai 2020
Statut
Membre
Dernière intervention
5 mai 2020

Tout fonctionne parfaitement merci beaucoup pour la solution !