Recherche multiples de chaine de caractère et formule matricielle

Fermé
Nicolasviolet - Modifié le 23 avril 2020 à 18:00
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 - 25 avril 2020 à 19:07
Bonjour,

Je cherche à faire ressortir des critères d'une zone de caractères de longueur et de contenu variable.

J'ai pour ça une table de critères et j'ai pensé aux formules matricielles pour faire une recherche "multiple" et me renvoyer le critère trouvé.

Par exemple si la chaine "crit1" se trouve dans la cellule A2, je veux que "crit1" apparaisse dans ma cellule.

{=SI(NB.SI(A2;"*"&$H$2:$H$4&"*");$H$2:$H$4)}


(les zones de caractères sont en colonne A, les critères en colonne H)


Seulement, cela fonctionne uniquement pour le premier critère de la table..

Je suis un bloqué et j'ai assez peu d'expérience avec les formules matricielles.

Merci d'avance pour vos lumières

lien vers le fichier : https://mon-partage.fr/f/yu265wvN/

PS: ma table de critères est assez longue donc je préférerai éviter de rechercher les critères 1 à 1
A voir également:

4 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
Modifié le 25 avril 2020 à 07:49
Bonjour
je pensais avoir déjà répondu sur ce sujet mais en fait c''était sur un post similaire?
voyez ici
https://mon-partage.fr/f/5TZ4j39y/
crdlmnt
1
Nicolasviolet
25 avril 2020 à 13:40
Bonjour et merci, seul soucis avec cette formule c'est que s'il n'y a pas lr critère dans la case, la formule cherche au plus proche.

J'ai eu cette proposition dans un autre forum qui fonctionne très bien :

=INDEX($H:$H;(MAX(ESTTEXTE(SI(NB.SI(A2;"*"&$H$2:$H$4&"*");$H$2:$H$4))*LIGNE($1:$3)))+1)
0
eriiic Messages postés 24494 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 janvier 2023 7 157 > Nicolasviolet
25 avril 2020 à 19:07
oui, doublon ici :
https://forum.excel-pratique.com/viewtopic.php?f=2&t=140473

A éviter stp, ou bien prévenir en mettant les liens.
Perso, quand je repère un demandeur qui agit ainsi, je zappe ses questions en me disant qu'il a peut-être la réponse ailleurs depuis plusieurs heures...
eric
0