Mise en forme Conditionnelle cellule vide [Résolu]

Signaler
Messages postés
139
Date d'inscription
samedi 24 décembre 2016
Statut
Membre
Dernière intervention
25 mai 2020
-
Messages postés
9573
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
1 octobre 2020
-
Bonjour,
J'applique cette formule pour colorier une cellule: =NBVAL(D23:I23)<>I20, comment la formuler pour que la formule ne s'applique pas si D23:I23 sont vides?(Vides de tout même de formules)
Merci pour votre réponse
Cordialement


Configuration: Windows / Chrome 81.0.4044.113

3 réponses

Messages postés
9573
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
1 octobre 2020
1 911
Bonjour

Tu peux essayer
=ET(D$23<>"";NBVAL($D$23:$I$23)<>$I$20)

Cdlmnt
Messages postés
139
Date d'inscription
samedi 24 décembre 2016
Statut
Membre
Dernière intervention
25 mai 2020

Impossible d'utiliser la formule il me met un message d'erreur.
Messages postés
9573
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
1 octobre 2020
1 911 >
Messages postés
139
Date d'inscription
samedi 24 décembre 2016
Statut
Membre
Dernière intervention
25 mai 2020

De rien

Chez moi elle fonctionne, mais ce n'est peut être pas ce que tu attendais (voir la proposition de notre ami Vaucluse)
https://mon-partage.fr/f/6iQznzGJ/

Cdlmnt
Messages postés
25333
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Bonjour (et salut ccm 81)
selon ce que j'ai compris je proposerais plutôt
=SI(ET(NB.SI($D$23:$I$23;"")<6;NBVAL($D$23:$I$23)<>$I$20))
de façon à n'éliminer la Mfc que si aucune cellule ne contient de valeur
crdlmnt
Messages postés
139
Date d'inscription
samedi 24 décembre 2016
Statut
Membre
Dernière intervention
25 mai 2020

Impossible d'utiliser la formule il me met un message d'erreur
Messages postés
25333
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Re
on peut se passer du SI en MFCet donc réduire les parenthèses
essayez ave"c

=ET(NB.SI($D$23:$I$23;"")<6;NBVAL($D$23:$I$23)<>$I$20)


crdlmnt