Disfonctionnement cgi-bin

Résolu
Bonjour,
Je n'arrive pas à faire fonctionner un programme mimetex.cgi. Quand je le charge avec le navigateur, j'ai un message d'erreur de configuration apache : Internal Server Error.

J'ai vérifié ma configuration.
Extraits de mon fichier httpd.conf :
<IfModule mod_alias.c>


    ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"

    <Directory "/usr/local/apache/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>

</IfModule>

...

<VirtualHost 91.121.79.159>
ServerAdmin webmestre@mathforu.com
        DocumentRoot /home/mathforu/www
        User mathforu
        Group users
ServerName www.mathforu.com
ServerAlias mathforu.com
        CustomLog logs/mathforu-access_log combined
ScriptAlias /cgi-bin/ /home/mathforu/cgi-bin/
</VirtualHost>


Et voici ce que je lis dans mes logs :

httpd/error_log
[Thu Sep 27 15:06:51 2007] [error] [client 90.1.60.227] Premature end of script headers: /home/mathforu/cgi-bin/mimetex.cgi


cgi.log
[2007-09-27 14:34:19]: info: (target/actual) uid: (mathforu/mathforu) gid: (users/users) cmd: mimetex.cgi
[2007-09-27 14:34:19]: error: file has no execute permission: (/home/mathforu/cgi-bin/mimetex.cgi)


Le problème est-il là ? Pouvez-vous m'aider à configurer correctement ou à trouver l'origine de mon problème ?

22 réponses

  1. Modérateur
    affiche à nouveau les logs
    2
    1. Modérateur
      Salut,

      affiche
      ls -l /home/mathforu/cgi-bin/mimetex.cgi
      --
      lami20j
      0
      1. # ls -l /home/mathforu/cgi-bin/mimetex.cgi
        -rw-r--r--    1 mathforu users      850321 sep 20 23:06 /home/mathforu/cgi-bin/mimetex.cgi
        
        


        Ce sont les mêmes droits que mon précédent serveur et qui fonctionnaient.
        0
        1. Modérateur
          chmod -v 0755 /home/mathforu/cgi-bin/mimetex.cgi
          et fait le test
          0
          1. error_log
            [Thu Sep 27 15:37:25 2007] [error] [client 194.214.150.9] Premature end of script headers: /home/mathforu/cgi-bin/mimetex.cgi

            cgi.log
            [2007-09-27 15:37:25]: info: (target/actual) uid: (mathforu/mathforu) gid: (users/users) cmd: mimetex.cgi
            [2007-09-27 15:37:25]: info: (target/actual) uid: (mathforu/mathforu) gid: (users/users) cmd: mimetex.cgi

            (une ligne de gagnée dans le cgi.log)
            0
            1. Modérateur
              oui, mais c'est fois il n'y a pas d'erreur
              donc c'est le moment de savoir ce que ton script doit faire
              ce qui est sur c'est que le script est bien exécuté
              0
              1. Modérateur
                ecrit dans
                /home/mathforu/cgi-bin/test.pl
                #!/usr/bin/perl -wT
                
                print "Content-type: text/html \n\n";
                print "Test"; 

                ensuite
                 chmod -v 0755 /home/mathforu/cgi-bin/test.pl
                et fait un test

                Peut être qu'il faut changer l'extension.
                Ton script est écrit dans quel langage?!
                0
                1. Il est là : http://thierry.leprof.free.fr/httpd/
                  0
                  1. Modérateur
                    essaie de mettre cette directive à dans ton hôte virtuel
                    Options Includes ExecCGI  MultiViews   FollowSymLinks Indexes
                    0
                    1. J'essaierai ce soir ... Je dois absolument partir (suis déjà en retard !)
                      Merci beaucoup : j'espère qu'on pourra reprendre plus tard.
                      0
                      1. J'ai mis ces directives mais .... pas de mieux.
                        Je les laisse ou je les enlève ?
                        Une autre idée ?
                        0
                        1. Modérateur
                          essaie
                          <VirtualHost 91.121.79.159>
                                  ServerAdmin webmestre@mathforu.com
                                  DocumentRoot /home/mathforu/sd/annuaire/www
                                  User mathforu
                                  Group users
                                  ServerName annuaire.mathforu.com
                                  CustomLog logs/annuaire.mathforu.com-access_log combined
                          	ScriptAlias /cgi-bin/ /home/mathforu/cgi-bin/
                                  <Directory "/home/mathforu/cgi-bin">
                                          AllowOverride None
                                          Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                                          Order allow,deny
                                          Allow from all
                                  </Directory>
                          </VirtualHost>
                          
                          0
                          1. Ouf, j'ai eu peur : je n'ai plus eu de site (page blanche !) même après avoir corrigé et relancé apache. Un reboot soft a arrangé les choses .... ;)

                            Je suppose que tu voulais plutôt que j'essaye :
                            <VirtualHost 91.121.79.159>
                                    ServerAdmin webmestre@mathforu.com
                                    DocumentRoot /home/mathforu/www
                                    User mathforu
                                    Group users
                                    ServerName www.mathforu.com
                                    CustomLog logs/mathforu-access_log combined
                            	ScriptAlias /cgi-bin/ /home/mathforu/cgi-bin/
                                    <Directory "/home/mathforu/cgi-bin">
                                            AllowOverride None
                                            Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                                            Order allow,deny
                                            Allow from all
                                    </Directory>
                            </VirtualHost>
                            
                            ?

                            J'ai essayé ce dernier code : non rien de mieux ....
                            0
                            1. Modérateur
                              regarde les messages privés
                              0
                              1. Oui c'est super ! Merci beaucoup ! A bientôt ...
                                0
                                • 1
                                • 2