Déterminer le mois d'une date

Signaler
Messages postés
2
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
9 avril 2020
-
Messages postés
16188
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 mai 2020
-
Bonjour,

Je voudrais savoir comment faire pour déterminer dans une cellule "B" le mois correspondant à une date située dans une cellule "A". Je tiens à préciser que le mois dont je parle part du 21 du mois précédent au 20 du mois en cours.

Exemple: le mois de Février part du 21 janvier au 20 Février.


Merci d'avance pour votre aide.

6 réponses

Messages postés
2641
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
27 mai 2020
661
Bonsoir,

Ma proposition avec date en A1

=SI(JOUR(A1)>20;MOIS(A1)+1;SI(JOUR(A1)<=20;MOIS(A1);""))


et pour éviter que la cellule marque un mois si A1 est vide

=SI(A1="";"";SI(JOUR(A1)>20;MOIS(A1)+1;SI(JOUR(A1)<=20;MOIS(A1);"")))


Cordialement
Messages postés
25106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 mai 2020
5 266
Bonjour
sauf si j'ai mal compris:
pour une date en A4 par exemple:
=SI(JOUR(A4)>=21;MOIS(A4)+1;MOIS(A4))
crdlmnt

Messages postés
2
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
9 avril 2020
1
Merci à tous. Mais lorsque j'entre ces différentes formules ce sont des chiffres qui apparaissent.
Messages postés
12232
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 mai 2020
1 860
Bonjour à tous

ou encore :
=MOIS(A4)+ARRONDI.INF(JOUR(A4)/21;0)

Cdlmnt
Via
Messages postés
2641
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
27 mai 2020
661
Bonjour

Si tu veux le nom des mois il faux ajouter :

=CHOISIR(la formule que tu as choisie (la partie après le =);"janvier";"février";"mars";"avril";"mai";"juin";"juillet";"août";"septembre";"octobre";"novembre";"décembre")

si tu as choisi ma deuxième formule

=SI(A1="";"";CHOISIR(SI(JOUR(A1)>20;MOIS(A1)+1;SI(JOUR(A1)<=20;MOIS(A1);""));"janvier";"février";"mars";"avril";"mai";"juin";"juillet";"août";"septembre";"octobre";"novembre";"décembre"))


Cordialement
Messages postés
16188
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 mai 2020
2 951
Bonjour à tous

encore une pour l'apéro en ces temps troublés:
=TEXTE(SI(JOUR(A4)>=21;MOIS.DECALER(A4;1);A4);"mmmm")