Modifier le contenu d'une colonne dans une fonction RechercheV / Index+Equiv

[Résolu/Fermé]
Signaler
Messages postés
19
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
30 mars 2020
-
Messages postés
19
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
30 mars 2020
-
Bonjour,

Je vous écris car je suis dans une impasse.. Voilà mon problème :

Je souhaite obtenir le numéro d'emplacement lié à un numéro d'article grâce à la fonction RechercheV. Je recherche l'emplacement associé à l'article 500-3215A. Or, dans ma base, l'article en question comporte une extension et s'écrit 500-3215A-C2.
Est-il possible de modifier l'écriture de la fonction RechercheV (ou Index+Equiv) pour demander à Excel de tronquer les 3 derniers caractères des numéros d'articles présents dans la première colonne de mon tableau ?
J'ai essayé de travailler sur les fonction RechercheV et Index+Equiv mais sans succès.. Existe-il un moyen de contourner ce problème sans avoir à créer une colonne supplémentaire dans mon tableau afin de supprimer cette extension ?

Je vous remercie d'avance pour votre aide.

1 réponse

Messages postés
1114
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
11 septembre 2021
241
Bonjour

Teste cette formule
=RECHERCHEV(B10&"*";$A$3:$B$7;2;FAUX)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42854 internautes nous ont dit merci ce mois-ci

Messages postés
19
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
30 mars 2020
1
Ça marche !!!
Merci beaucoup c'est parfait !!