Recherche un chiffre dans une cellule contenant texte et chiffre [Résolu]

Signaler
Messages postés
7
Date d'inscription
lundi 16 mars 2020
Statut
Membre
Dernière intervention
24 mars 2020
-
Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
-
Bonjour,

J'ai deux feuilles excel ce que je souhaiterai c'est si une cellule contient un chiffre qui appartient à une cellule cela recherche la valeur qui est dans la colonne 2

Je vous joins l'exemple :

Si la valeur boutique contient le code 123456 alors je recherche la valeur résultat certification

Merci d'avance pour votre aide



Configuration: Windows / Chrome 80.0.3987.149

9 réponses

Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Alors j'ai testé cette formule ; chez moi elle fonctionne avec une recopie des images en mettant 7 chiffres au début

En I2 de "feuil1" :

=SIERREUR(RECHERCHEV(CNUM(GAUCHE(C2;7));Feuil2!A:B;2;0);"non certifié")

Si ça ne convient pas envoyez une copie du fichier (sans données confidentielles) via https://www.cjoint.com/ ou https://mon-partage.fr/

Cordialement
Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Vu le fichier, il fallait ajouter un 0 sur le code de C3 pour qu'il corresponde au A4 de la feuille 2

et I2

=SIERREUR(RECHERCHEV(CNUM(GAUCHE(C2;7));Feuil2!A:B;2;0);"")

Cordialement
Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Bonjour,

Une proposition en B2 de la feuille 2

=SI(NB.SI(Feuil1!C:C;"*"&A2&"*")>0;"certifié";"non certifié")

Cordialement
Messages postés
7
Date d'inscription
lundi 16 mars 2020
Statut
Membre
Dernière intervention
24 mars 2020

En fait la valeur en B2 de la feuille 2 je souhaite la reporter dans la colonne I de la feuille 1
Messages postés
2770
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 septembre 2020
727
Le code comporte-t-il toujours 6 chiffres ???

Cordialement
Messages postés
7
Date d'inscription
lundi 16 mars 2020
Statut
Membre
Dernière intervention
24 mars 2020

il en comporte exactement 7 qui est différent en fonction du nom
Messages postés
25287
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
5 466
Bonjour
si vous avez toujours un blanc entre le c ode chiffré et les lettres qui suivent:
pur un code en C2:
=SIERREUR(GAUCHE(C2;TROUVE(" ";C2)-1);"")
et si vous voulez numériser le résultat (qui reste un texte sinon)
=SIERREUR(GAUCHE(C2;TROUVE(" ";C2)-1)*1;"")
crdlmnt


Messages postés
7
Date d'inscription
lundi 16 mars 2020
Statut
Membre
Dernière intervention
24 mars 2020

Messages postés
25287
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
5 466
Re
votre fichier présente des bizarreries dont il faudrait confirmer si elles sont normales ou non
entre autre le code en C3 de feuil1 qui comporte un0 de moins qu'en A4 de feuil2?
sin c'est une anomalie, cette formule en I2 devrait faire l'affaire, comme dans ce modèle joint
=SI(C2="";"";SIERREUR(RECHERCHEV(GAUCHE(C2;TROUVE(" ";C2)-1)*1;Feuil2!A:B;2;0);"non précisé"))
https://mon-partage.fr/f/gDT174B2/
a suivre?
crdlmnt
Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
3 030
Bonjour

Avec une fonction VBA personnalisée, chiffres regroupés quelquesoit leur nombre

https://mon-partage.fr/f/QlgqicVX/

il peut y avoir un problème avec Win 10