Apache2

Fermé
orck - 4 mars 2020 à 20:39
mamiemando
Messages postés
31045
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
14 mai 2022
- 6 mars 2020 à 09:55
Bonjour,
j'ai installer apache2 avec php et mysql pour pouvoir deployer un logiciel TAO mais lorsque je tape la commande http://localhost on me dit ''not found'' ou ''forbidden'' . Pouvez vous m'aider?


Configuration: Windows / Chrome 78.0.3904.87

3 réponses

mamiemando
Messages postés
31045
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
14 mai 2022
7 346
5 mars 2020 à 10:53
Bonjour,

Quelle distribution linux utilises-tu ?

Sous debian par exemple, il suffit d'installer en root les paquets adéquats :

apt update
apt upgrade
apt install apache2 default-mysql-server libapache2-mod-php
a2enmod php7.4


Note qu'ici la commande
a2enmod
(apache2 enable module) active le module php. Corrige au besoin la version du module (voir
/etc/apache2/mods-available/
). La commande réciproque est
a2dismod
(apache2 disable module).

À ce stade tu devrais avoir un virtual host par défaut qui devrait afficher "It works" si tu ouvres http://localhost qui correspond en pratique à
/var/www/index.html
.

Et normalement, installer des logiciels construits sur LAMP (genre phpmyadmin etc) devrait installer un vhost dédié (dans cet exemple précis, exploité lorsqu'on visite http://localhost/phpmyadmin) ...

Sur le même principe,
a2ensite
et
a2dissite
permettent d'activer ou désactiver un vhost déclarés dans
/etc/apache2/sites-available
.

Bonne chance
0
Ma distribution linux c'est ubuntu
Et mon hôte http://localhost ne s'affiche plus. On me met not round ou forbidden
0
mamiemando
Messages postés
31045
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
14 mai 2022
7 346
6 mars 2020 à 09:55
As-tu essayé ce que je t'ai dit ?
0