Formule pour afficher une cellule en fonction de la date [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
lundi 2 mars 2020
Statut
Membre
Dernière intervention
11 mars 2020
-
Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021
-
Bonjour à toutes et à tous,

J'ai un problème pour afficher la cellule "trimestre" qui correspond à la date que je vais rentrer en colonne B. Je souhaiterai pouvoir en fonction de la date afficher le trimestre correspondant.

Je ne sais pas si la fonction "SI" est la plus pertinente dans mon cas et voici ce que j'ai essayé ci-dessous.

=SI(ET(B2>=E2;B2<=F2);G2);SI(ET(B2>=E3;B2<=F3);G3); SI(ET(B2>=E4;B2<=F4);G4); SI(ET(B2>=E5;B2<=F5);G5) ;…. ; SI(ET(B2>=E11;B2<=F11);G11))

Merci d'avance pour votre aide.
Cordialement
Mathias

3 réponses

Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021
1 089
Bonsoir
une autre piste
en B1
=RECHERCHEV(B2;$E$2:$G$11;3;1)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021
1 089
Re
Une autre solution
="Q"&ARRONDI(MOIS(B2)/4;0)+1&"-"&ANNEE(B2)
Messages postés
7
Date d'inscription
lundi 2 mars 2020
Statut
Membre
Dernière intervention
11 mars 2020
>
Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021

Merci yclick !
Il me reste maintenant à comprendre la logique de cette formule pour être en mesure de la réutiliser à l'avenir ou voir même de l'expliquer à une autre personne.
Cordialement
Mathias
Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021
1 089 >
Messages postés
7
Date d'inscription
lundi 2 mars 2020
Statut
Membre
Dernière intervention
11 mars 2020

Bonjour
désolé mais, en restant, la formule ne fonctionne pas bien
il faut
="Q"&ENT((MOIS(B2)-1)/3)+1&"-"&ANNEE(B2)


ENT((MOIS(B2)-1)/3)+1 calcule le trimestre

A tester voir si l'affichage en trimestre vous conviendrait
dans le format date
Q-AAAA qui donne T1-2019
Messages postés
3218
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 avril 2021
897 >
Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021

Salut Yclik

Celle-là fonctionne mieux en effet, la première donnait le trimestre 2 pour février à mai et 3 pour juin à septembre.
Cordialement
Messages postés
2427
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 avril 2021
1 089 >
Messages postés
3218
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 avril 2021

Bonjour PapyLuc51
effectivement, voilà ce que c'est d'aller trop vite sans tout tester !
Messages postés
3218
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 avril 2021
897
Re:

C'est une concaténation c'est à dire l'ajout d'éléments les uns derrière les autres en utilisant le &

="Q" on inscrit la lettre Q

CHOISIR(MOIS(B2);1;1;1;2;2;2;3;3;3;4;4;4) ici on cherche le numéro du mois de la date inscrite en B2 ( de 1 à 12 ) et en fonction du numéro du mois, la fonction CHOISIR donne le numéro du trimestre 1 pour les mois 1,2,3 ; 2 pour les mois 4,5,6 ; etc...

"-" là on ajoute un tiret pour séparer le numéro du trimestre et l'année

ANNEE(B2) donne l'année de la date en B2

La formule normale est

=CONCATENER("Q";CHOISIR(MOIS(B2);1;1;1;2;2;2;3;3;3;4;4;4);"-";ANNEE(B2))

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
7
Date d'inscription
lundi 2 mars 2020
Statut
Membre
Dernière intervention
11 mars 2020

Merci beaucoup PapyLuc51 pour cette explication limpide qui m'a aidé à bien comprendre l'utilisation de la fonction CONCATENER.
Bonne journée à vous
Mathias
Messages postés
3218
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 avril 2021
897
Bonjour,

Pour la du 01/10/2019 en B2 ;

En C2 cette formule :

="Q"&CHOISIR(MOIS(B2);1;1;1;2;2;2;3;3;3;4;4;4)&"-"&ANNEE(B2)

pour obtenir Q4-2019

Cordialement
Messages postés
7
Date d'inscription
lundi 2 mars 2020
Statut
Membre
Dernière intervention
11 mars 2020

Bonjour PapyLuc51,
Merci pour votre réponse que je ne suis pas certain de bien comprendre.
Pourriez-vous me détailler un peu plus la formule à rentrer dans la colonne C2.
En vous remerciant par avance pour votre aide ^précieuse.
Mathias