Fonction décaler + Nb.si [Résolu]

Signaler
Messages postés
43
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
2 octobre 2020
-
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
-
Bonjour,

J'ai une formule qui s'écrit comme suit :

NB.SI(FEUILLE1!AA$1:AB$60;"OK")

Je souhaite l'appliquer sur plusieurs colonnes. Quand j'étire vers la droite avec le petit 'plus', j'ai cette formule dans la case suivante :

NB.SI(FEUILLE1!AB$1:AC$60;"OK")

Ce que je souhaite obtenir quand j'étire vers la droite c'est :

NB.SI(FEUILLE1!AC$1:AD$60;"OK") puis

NB.SI(FEUILLE1!AE$1:AF$60;"OK") puis

NB.SI(FEUILLE1!AG$1:AH$60;"OK")...

Que la formule se décale d'une colonne !
J'ai essayé avec décaler mais je n'y arrive pas !

Merci d'avance pour votre aide.


Configuration: Android / Firefox 68.0

3 réponses

Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 926
En C2 de la feuille 2
=NB.SI(DECALER(Feuil1!$B$1;0;(COLONNE()-3)*2;40;2);"OK")

Cdlmnt
Messages postés
43
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
2 octobre 2020

Un gigantesque merci, du fond du cœur. Résolu ????
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 926 >
Messages postés
43
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
2 octobre 2020

De rien

Bonne journée

Cdlmnt
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 926
Bonjour

Formule à adapter

K1 =NB.SI(DECALER($B$1;0;(COLONNE()-11)*2;1;2);"OK")

11 est le N° de la première colonne pour la formule ici K

https://mon-partage.fr/f/dBspAnox/

Cdlmnt
Messages postés
43
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
2 octobre 2020

Bonjour,

J'ai modifié votre fichier pour mieux expliquer mon souci.

La formule avec NB.SI gère une plage complète et pas seulement une ligne.

Merci d'avance

https://www.cjoint.com/c/JBBjicOhuT3
Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 926
K1 =NB.SI(DECALER($B$1;0;(COLONNE()-11)*2;40;2);"OK")

40 : nombre de lignes à prendre

https://mon-partage.fr/f/tz0oA17S/

Cdlmnt
Messages postés
43
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
2 octobre 2020

Excusez-moi mais je pense que les choses ne sont pas claires.

La formule se trouve sur la feuille 2! Cette formule calcule les données de la feuille 1. La formule décaler doit être dans la formule qui se trouve en c2 de la feuille 2 !

N'est-ce pas ?