Comment calculer l'âge au 01/01 excel [Résolu]

Signaler
Messages postés
181
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
29 juin 2020
-
Messages postés
181
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
29 juin 2020
-
Bonjour,

Je souhaite attribuer une donnée aux personnes ayant 29 ans et moins au 01/01 de l'année en cours. Je n'ai pas trouvé de formule pour cela.

En A1 =Aujourdhui()
En A2 = Date de naissance

En b1 = 10 (donnée à attribuer de 29 ans et moins au 01/01)
En B2 = 20 (donnée à attribuer de 30 ans à 49 ans au 01/01)
En B3 = 30 (donnée à attribuer de 50 ans à 59 ans au 01/01)

Exemple : une personne ayant 29 ans et moins au 01/01/2019, aura 10......etc

Merci d'avance,

Configuration: Windows / Internet Explorer 11.0

3 réponses

Messages postés
25159
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour
=SI(A2="";"";SI(DATEDIF(A2;DATE(ANNEE(A1);1;1);"y")<30;10;SI(DATEDIF(A2;DATE(ANNEE(A1);1;1);"y")<50;20;30)))
crdlmnt
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour

A1 = CNUM("01/01/"&ANNEE(AUJOURDHUI()))
B2 =ANNEE(A1)-ANNEE(A2)
C2= RECHERCHEV($B$2;$E$1:$F$4;2;VRAI)

En colonne E et F mettre les âges et les valeurs correspondantes
E1 =1 E2 = 29 E3 =30 E4= 50
F1=rien F2= 10 F3= 20 F4= 30

Messages postés
181
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
29 juin 2020
2
Bonjour à tous les deux,

Un grand Merci, pour votre contribution rapide et efficace !

Les 2 solutions fonctionnent ????

Bonne journée !