Calcul petite valeur = 0

Signaler
Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019
-
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
-
Bonjour,

J'ai un petit problème avec la fonction petite valeur.

Je veux attribuer des notes (maximum 7) à des compagnies d'assurance proposant des franchises d'assurance.

Le calcul est : Franchise la moins élevée X 7 / Franchise proposé.

Je n'arrive pas à la calculer avec la fonction petite valeur. il donne erreur #DIV/0!

Voir le fichier ci-joint

https://www.cjoint.com/c/IKkk16AMf0b

Merci

4 réponses

Messages postés
2096
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
344
Bonjour
Formule à tester
=SIERREUR(PETITE.VALEUR($B$5:$B$10;1)/($B5*$C$4);0)
Cordialement
Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019

ça n'a pas marché, elle donne 0 pour tous...
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonjour
tant que vous aurez des 0 dans vos tableaux, Excel ne vous renverra que des 0 ou des 3DIV/0 puisque vous divisez par zéro
par ailleurs Excel prend 0 comme petite valeur tant que vous n'aurez pas éliminé le nombre de 0 en B5:B10 de votre formule
essayez avec:
=SI(B5=0;"";PETITE.VALEUR($B$5:$B$10;NB.SI($B$5:$B$10;0)+1)/$B5*$C$4)

ou alors conservez votre formule après le SI(B5=0, mais dans ce cas effacer les 0 en B pour que PERTITE.VALEUR ne les prenne pas en compte

reste à savoir ce que vous voulez comme résultat si B=0 ou vide?
vous pouvez le placer à la place ou entre les guillemets selon que votre choix soit num ou alpha)
crdlmnt

Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019

si B=0, je veux comme résultat 7 puis la règle (Franchise la moins élevée X 7 / Franchise proposé).
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
alors:
=SI(B5=0;7;PETITE.VALEUR($B$5:$B$10;NB.SI($B$5:$B$10;0)+1)/$B5*$C$4)
mais je n suis pas certain que le résultat soit celui cherché en cas de franchise à moins de 0.5

CR5DLMNT
Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019

ça n'a encore pas marché
Messages postés
2096
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
344
Voir celle-ci

=SI(B5=0;7;PETITE.VALEUR($B$5:$B$10;NB.SI($B$5:$B$10;0)+1)/$B5*$C$4)
Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019

La compagnie qui a proposé une valeur supérieure à 0 a quand même obtenue la note complete avec celle qui a proposé 0.....C'est pas ça qu'on veut...
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
https://mon-partage.fr/f/MIYguS7t/
Messages postés
2096
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
344
Voir ci-dessous
=SIERREUR(SI(B5=0;7;PETITE.VALEUR($B$5:$B$10;NB.SI($B$5:$B$10;0)+1)/$B$5/$C$4);"")
Messages postés
29
Date d'inscription
jeudi 8 février 2018
Statut
Membre
Dernière intervention
10 novembre 2019

ça n'a pas marché...les autres n'ont pas pu obtenir leur note
Messages postés
25467
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
vous pouvez renvoyer le modèle que je vous propose un peu plus haut avec des commentaires? surtout avec des exemples sur "les autres"?