Fonction SI + ET + OU doublées [Résolu]

Signaler
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019
-
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019
-
Bonjour,

Je me permets de poser ici ma question puisque je n'ai pas trouvé de sujet regroupant toutes mes demandes ...

Je suis en train de m'arracher les cheveux sur une formule Excel ... J'ai une liste de salariés dont le statut peut être A, B, C ou D, et leur ancienneté dans l'entreprise. Les salariés qui sont en statut ( en colonne E) A et B et qui ont + d'1 an d'ancienneté (colonne K) ont droit au cadeau, les salariés en statut C ou D qui ont moins d'1 an d'ancienneté ont droit à 75% du cadeau, ceux qui ont plus d'1 an d'ancienneté ont droit au cadeau.

Je pose toujours par écrit ma formule avant de la convertir sur Excel, soit :

Si le statut d'un salarié est A ou B ET que son ancienneté est supérieure à 1 an, alors Oui sinon Non, ET si le statut du salarié est C ou D ET que son ancienneté est inférieure à 1 an alors 75% sinon Oui.

Que je traduis sur Excel de cette manière :
=SI(OU(Colonne E="A";Colonne E="B")*ET(Colonne K<365);"Oui";"Non")*ET(SI(OU(Colonne E="C";Colonne E="D")*ET(Colonne K>365);"Oui - 75%";"Oui"))

J'ai essayé de remanier ma formule à plusieurs reprises mais elle refuse de fonctionner ... Je pense que mon erreur doit être toute bête mais je ne parviens pas à mettre le doigt dessus d'où le besoin de votre éclairage :)

Merci beaucoup à celles et ceux qui me viendront en aide !

5 réponses

Messages postés
2443
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 septembre 2020
1 223
Bonjour,

Pouvez-vous me dire si ca vous correspond:

=SI(Ou(E2="A";E2="B");Si(K2<365;"Oui";"Non");Si(K2>365;"Oui -75%";"Oui"))

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

Bonjour,

Merci beaucoup pour votre réponse ! Malheureusement il manque une partie de la formule ... A savoir si le statut du salarié est C ou D ...
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

Votre formule attribue 75% du cadeau à tous si l'ancienneté est inférieure à 1 an, or il n'y a que les salariés en statut C ou D qui l'ont, ceux en statut A ou B avec une ancienneté inférieure à 1 an n'ont pas droit au cadeau ...
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

D'où l'arrachage de cheveux ! Je préférerais leur donner à tous les cadeaux ^^
Messages postés
2443
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 septembre 2020
1 223
Bonjour,

Pas besoin normalement de la partie Statue... car si un salarié n'est ni A ou B, il est forcémen C ou D .

Ce qui veut dire:
A ou B et moins d'un an => Oui
A ou B et plus d'un an => Non
C ou D et moins d'un an => Oui
C ou D et plus d'un an => Oui -75
Messages postés
2443
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 septembre 2020
1 223
Il y a une erreur dans ma formule,

essayez celle la :
=SI(Ou(E2="A";E2="B");Si(K2>365;"Oui";"Non");Si(K2>365;"Oui -75%";"Oui"))
Messages postés
840
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 septembre 2020
173
Bonjour
Teste la formule
=SI(ET(OU(E2="A";E2="B");K2<365);"Non";SI(ET(OU(E2="C";E2="D");K2<365);"Oui - 75%";"Oui"))
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

Bonjour !

Votre formule fonctionne !

Pourriez-vous m'indiquer l'erreur que j'avais faite dans ma formule ? Peut-être la surcharger en y mettant trop de conditions ?

Merci beaucoup !
Messages postés
25299
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
Bonjour
et comme ça pour des valeurs en ligne 1

=SI(ET(OU(E1="A";E1="B");K1<365);"Oui";SI(ET(OU(E1="C";E1="D");K1>365);"Oui - 75%";"non"))

crdlmnt
Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

Bonjour,

J'ai eu ma réponse ci-dessus mais je vous remercie de votre réponse !

Bonne journée à vous !
Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
3 031
Bonjour
en guise d'apéro
=SI(E2<="B";SI(K2>365;"oui";"non");SI(K2>365;"oui";"oui-75%"))

Messages postés
9
Date d'inscription
vendredi 12 avril 2019
Statut
Membre
Dernière intervention
6 novembre 2019

Merci à tous pour vos réponses ! Cela fonctionne ! Et j'ai bien compris que plus la formule est longue plus il y a de risques d'erreurs.
Il faut donc que je pense dorénavant à raccourcir mes formules, en n'omettant pas de suivre la logique d'Excel et en ne surchargeant pas mes formules de trop de conditions.

Merci beaucoup et bonne journée à tous :)