Problème tomcat [Fermé]

Signaler
Messages postés
157
Date d'inscription
lundi 24 septembre 2018
Statut
Membre
Dernière intervention
31 août 2020
-
Messages postés
157
Date d'inscription
lundi 24 septembre 2018
Statut
Membre
Dernière intervention
31 août 2020
-
Bonjour,

Je viens tout juste de créer un projet java EE pour développer une application web. Je suis le tuto d'openclasseroom. Lors que je fais "run as" puis "run on serveur", voila ce que j'obtiens :



et dans mon server.xml j'ai des trucs sousligné :



voila merci de votre aide

1 réponse

Messages postés
16120
Date d'inscription
samedi 31 mai 2008
Statut
Modérateur
Dernière intervention
27 novembre 2020
2 738
Bonjour,

Le soulignement dans le fichier xml c'est le correcteur orthographique qui ne reconnaît pas certains mots.

Quant à l'erreur 404, ça veut dire que /application ne correspond à rien sur le serveur, mais sans plus d'information ce sera impossible de t'aider, le web.xml ce serait un début...
Messages postés
1
Date d'inscription
jeudi 29 mars 2018
Statut
Membre
Dernière intervention
31 octobre 2019

En voyant le code d'erreur, c'est que le lien auquel tu veux accéder est introuvable sur le serveur. Rassure-toi d'avoir spécifier une url existante dans la déclaration de tes fichiers index au niveau du fichier de déploiement web.xml.

Vérifie si tu as un bout de code ressemblant à ceci:

<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
<welcome-file>index.html</welcome-file>
</welcome-file-list>

Lorsque le lien n'est pas expressément spécifié par l'utilisateur, le serveur charge une page par défaut, que le développeur spécifie dans le web.xml.

Il faut noter que si tu mets index.jsp, le fichier doit bien exister.
Messages postés
157
Date d'inscription
lundi 24 septembre 2018
Statut
Membre
Dernière intervention
31 août 2020

Bonjour, en fait c'etait mon application qui était mauvaise et qui bloquait monn serveur. Cependant, je n'avais pas de web.xml de créé, j'ai du donc le créer :



Cependant, lorsque j'execute mon application (elle envoie une requête http pour récupérer une réponse en JSON d'un logiciel de gestion), une boite de dialogue apparait pour mettre ma KEY token/code pour accéder à l'api, elle me renvoie la réponse (que je dois télécharger, donc un peu chiant, j'aimerai la récupérer dans un string ou autre pour ensuite la parser), puis le serveur plante et impossible de le redémarrer saut si je surprime une fois de plus l'appli de mon serveur.

code de ma servlet :

package com.journaldev.first;

import java.io.IOException;
import java.io.PrintWriter;
import java.util.Date;

import javax.servlet.ServletException;
import javax.servlet.annotation.WebInitParam;
import javax.servlet.annotation.WebServlet;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;

/**
 * Servlet implementation class FirstServlet
 */
@WebServlet(description = "My First Servlet", urlPatterns = { "https://sogecap.eu.teamwork.com/tasks.json?responsible-party-ids=229486"})
public class FirstServlet extends HttpServlet {
	
	private static final long serialVersionUID = 1L;
	public static final String HTML_START="<html><body>";
	public static final String HTML_END="</body></html>";
       
    /**
     * @see HttpServlet#HttpServlet()
     */
    public FirstServlet() {
        super();
        // TODO Auto-generated constructor stub
    }

	/**
	 * @see HttpServlet#doGet(HttpServletRequest request, HttpServletResponse response)
	 */
	protected void doGet(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException {
		//PrintWriter out = response.getWriter();
		
		//Date date = new Date();
		//out.println(HTML_START + "<h2>Hi There!</h2><br/><h3>Date="+date +"</h3>"+HTML_END);
	}

	/**
	 * @see HttpServlet#doPost(HttpServletRequest request, HttpServletResponse response)
	 */
	protected void doPost(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException {
		// TODO Auto-generated method stub
	}

}