MKVtoolnix GUI [Fermé]

Signaler
-
 Goodkind -
Bonjour. J'ai installé sur PC Windows 10 de nombreuses versions de ce logiciel (anciennes et récentes) mais aucune ne me permet d'ouvrir MKVMERGE (un écran noir défile avec des lignes successives...
Avez-vous une solution ?
D'avance merci beaucoup.

6 réponses

Messages postés
18942
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
3 928
Bonsoir,

Alors.. Mkvmerge avec Windows 10...?? ...?? On est à la version 38 en 64 bit... sur windows 7 pro, ça marche... Windows 10, je sais pas...
Regarde bien tes versions... si tu défile en noir, je soupçonnerais bien que tu déclenche dans une fenêtre DOS si tu lance directement la commande MKVMERGE, c'est le cas.

Il faut choisir pour le lancement, sur ancienne version: mmg.exe et sur la dernière version : mkvtoolnix-gui.exe ainsi tu as une interface graphic... je crois que c'est ça ton problème...

Sinon, il y a aussi AVIdemux 64 qui fait pas mal de chose https://avidemux.fr.uptodown.com/windows
Bonjour Jeannets et merci pour ta réponse. Oui j'avais également téléchargé la version 38 en 64 bits et oui j'ai également cliqué sur mkvtoolnix-gui.exe et j'ai bien une fenêtre qui s'ouvre mais le problème est là : j'ajoute une video, j'ajoute également un sous titre SRT ou SSA. Je lance le muxage et au résultat aucun
sous titre n'apparaît sur la video... Antérieurement des versions plus anciennes de Toolnix m'ont effectivement fonctionné sur des versions également plus anciennes de windows. Peut-être le problème vient-il du windows 10 pro que j'utilise actuellement ? Pour ma part, je n'ai jamais utilisé AVIdemux.
Si quelqu'un a une idée du problème, merci d'avance.
Messages postés
18942
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
3 928
Je ne sais pas te répondre avec Windows 10.. Beaucoup de choses sont devenues "compliquées" ou prennent beaucoup de temps avec cet OS... je fais donc autrement.

Dans ton cas, ce peut etre ta vidéo la cause du problème... selon comment elle est encodée, son bitRate le Nb d'images références etc.. et ton sous titre n'arrive pas à se synchroniser dessus...
Une fois de plus merci Jeannets. Je pense que même si le ST n'était pas synchronisé, il apparaîtrait de temps en temps sans correspondre à l'audio mais là rien de rien. Je vais supprimer MKVtools de mes logiciels, c'est plus simple. C'était pour éviter d'incruster les ST et simplement muxer mais en matière d'incrustation, ce merveilleux logiciel qu'est FormatFactory le fait parfaitement - entre autres choses...
Messages postés
18942
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
3 928
Avidemux le fait aussi... c'est en quelque sorte l'application graphic de "Mencoder" si ça te dit quelque chose
https://forum.hardware.fr/hfr/VideoSon/Traitement-Video/topic-unique-mencoder-sujet_87558_1.htm

http://www.mplayerhq.hu/DOCS/HTML/fr/encoding-guide.html

Avec un system de ce genre qui travaille en lignes de commande, un encodage va très vite et c'est proportionnel à la puissance de calcul du processeur... Avec un Ryzen 7 2700X un encodage totale dure autour de 4 minutes.
Bonjour Jeannets. Encore moi. J'ai décidé d'essayer Avidemux et je l'ai installé sur PC. Heureusement il y a des tutos pour aider à l'utiliser mais quand je veux inclure mes sous titres à la video/audio, soit en SRT, soit en SSA, le programme dit qu'il ne les reconnait pas....Tu as une idée ??? Merci d'avance.
Messages postés
18942
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
3 928
Ma première idée, c'est que ton fichier SRT ou SSA n'est pas conforme à la règle... quelque chose ne va pas. particulièrement le nom du fichier qui doit etre le même que la vidéo... Il y a peut etre un caractère ou une vigule, ou un espace de différence.

Voici un outil de conversion https://www.commentcamarche.net/faq/17393-convertir-des-fichiers-de-sous-titres-srt-sub-ssa-txt en espérant que ça t'aide.... il y a même une vidéo.

Il y a aussi un logiciel pour ce sous-titrage et le timing http://www.visualsubsync.org/

et ce tuto Vidéo et explications ici http://www.planetenumerique.com/guides-dossiers/SubSync-synchronisez-et-creez-vos.html
Messages postés
23695
Date d'inscription
dimanche 1 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
4 924
Bonjour,

MKVToolnix (perso, j'utilise la version portable) n'incruste pas les sous-titres dans la vidéo, il ne fait qu'encapsuler en plus les sous-titres dans le conteneur MKV.
C'est à toi ensuite d'aller les activer avec le lecteur employé.

Vérifie avec par exemple MediaInfo que tes pistes de sous-titres sont bien présents dans ton fichier.

Cordialement
Bonjour Ziggourat. Merci pour tes infos. Oui je sais que MKVToolnix encapsule les ST (pas d'incrustation). Je l'utilisais il y a plusieurs années (MKVMerge) sans problème avec windows 7. Peut-être que c'est mon windows 10 pro qui cause problèmes...L'opération de muxage était hyper simple et rapide. Cependant je ne savais pas comment augmenter la taille de mes sous titres avec ce logiciel. Ils sortaient toujours très petits sur ma TV. Maintenant si je mets l'icône de MKV merge sur le bureau j'ai apparemment le Dos qui défile (écran noir et lignes). Si j'ouvre MKV Toolnix sur le bureau, je peux ajouter video/audio et ST mais à la fin pas de ST sur la video...Alors tant pis, je suis retournée avec l'incrustation via FormatFactory ou Avidemux indiqué par Jeannets. Bonne journée. Je vérifierai quand même avec MediaInfo... Cordialement.