Afficher des dates en fonction du n° de semaine et de l'année [Résolu/Fermé]

Signaler
Messages postés
10
Date d'inscription
mercredi 2 octobre 2019
Statut
Membre
Dernière intervention
8 octobre 2019
-
Messages postés
10
Date d'inscription
mercredi 2 octobre 2019
Statut
Membre
Dernière intervention
8 octobre 2019
-
Bonjour,

J'ai le no de semaine en E4, et l'année en G3

- J'aimerais afficher dans une cellule, les dates sous le format ("du" XX/XX/XX "au" XX/XX/XX) qui correspondent du lundi au dimanche pour la semaine E4

- afficher en C14, le 1er jour de la semaine, au format "Lundi XX 'mois en clair'"

C'est toujours pour ma gestion de planning!
Merci d'avance pour votre aide
Gilles

Configuration: Windows / Chrome 77.0.3865.90

5 réponses

Messages postés
2960
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
17 janvier 2021
411
Bonjour à tous,

en c14 tu mets

=DATE(ANNEE(g3);1;7)-MOD(DATE(ANNEE(g3);1;7)-2;7)+7*(e4-1')
Pas de moi la formule
et tu choisis un format personnalisé en jjjj jj mmmm.

(pas de majuscule a lundi, c'est américain)

Crdlmt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
12905
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 janvier 2021
2 102
Re ☺

Je suis prêt !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
12905
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 janvier 2021
2 102
Bonjour à vous 2

Pour la 1ere demande :
="du " & TEXTE(7*E4+DATE(G3;1;3)-JOURSEM(DATE(G3;1;3))-5;"jj/mm/aa") &" au " & TEXTE(6 +7*E4+DATE(G3;1;3)-JOURSEM(DATE(G3;1;3))-5;"jj/mm/aa")

Cdlmnt
Via
Messages postés
10
Date d'inscription
mercredi 2 octobre 2019
Statut
Membre
Dernière intervention
8 octobre 2019

Bonjour Via! :) :)
Encore une réponse pertinente!
Un grand merci
La météo n'étant pas favorable, mon planning avance, lol
Après la phase de "remplissage", je vais bientôt créer 2 nouvelles feuilles pour les éditions, attention à l'avalanche de questions à venir! :)
Cordialement
Messages postés
10
Date d'inscription
mercredi 2 octobre 2019
Statut
Membre
Dernière intervention
8 octobre 2019

il y a également la formule:

="Du "&TEXTE(DATE(ANNEE(AUJOURDHUI());1;-2)-JOURSEM(DATE(ANNEE(AUJOURDHUI());1;3))+A3*7;"jjjj jj mmmm aaaa")&" au "&TEXTE(DATE(ANNEE(AUJOURDHUI());1;-2)-JOURSEM(DATE(ANNEE(AUJOURDHUI());1;3))+(A3*7)+6;"jjjj jj mmmm aaaa")
(avec un numéro de semaine en A3)
Messages postés
8348
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
16 janvier 2021
1 565
Avec l'année en G3, l'an prochain ça marchera plus !
Messages postés
2960
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
17 janvier 2021
411
D'autant plus que ce n'est pas la réponse a la question posée :
"-afficher en C14, le 1er jour de la semaine, au format "Lundi XX 'mois en clair'"
On ne parle pas de l'année

Crdlmt
Messages postés
8348
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
16 janvier 2021
1 565 >
Messages postés
2960
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
17 janvier 2021

Un peu quand même, c'est la première des deux questions :
« J'ai le no de semaine en E4, et l'année en G3
- J'aimerais afficher dans une cellule, les dates sous le format ("du" XX/XX/XX "au" XX/XX/XX) qui correspondent du lundi au dimanche pour la semaine E4 »
Messages postés
10
Date d'inscription
mercredi 2 octobre 2019
Statut
Membre
Dernière intervention
8 octobre 2019

pour afficher le 1er jour de la semaine:

lundi
=TEXTE(DATE(ANNEE(AUJOURDHUI());1;-2)-JOURSEM(DATE(ANNEE(AUJOURDHUI());1;3))+E4*7;"jjjj jj mmmm aaaa")

mardi
=TEXTE(DATE(ANNEE(AUJOURDHUI());1;-2)-JOURSEM(DATE(ANNEE(AUJOURDHUI());1;3))+(E4*7)+1;"jjjj jj mmmm aaaa")

etc!

je ne me sers plus de l'année!
Juste le n° de semaine en E4