Comment effacer "# nombre!" tout en gardant ma formule [Résolu/Fermé]

Signaler
-
 cdav2 -
Bonjour,
J'ai trouvé sur un forum, une formule pour avoir le numéro de semaine (En B1) quand je tape la date dans la précédente (A1).

Voici la formule :
=ENT((A1-(DATE(ANNEE(A1-JOURSEM(A1-1)+4);1;3)-JOURSEM(DATE(ANNEE(A1-JOURSEM(A1-1)+4);1;3)))+5)/7)

Malheureusement, quand ma case (A1) est vide, "#nombre!" s'affiche en B1.

Comment puis-je garder ma formule tout en ayant ma case vide. (pour avec un tableau plus"propre").

Merci pour votre aide.

PS : si vous avez également une formule plus simple pour obtenir le numéro de semaine, je suis preneurs.


Configuration: Windows / Chrome 77.0.3865.90

1 réponse

Messages postés
23499
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
6 360
Bonjour,

=SIERREUR(NO.SEMAINE(A2;21);"") 

ou si tu as une version récente d'excel :
=SIERREUR(NO.SEMAINE.ISO(A2);"")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Merci Eric,

j'ai effectivement la dernière version.
Super pour la formule,
Mais quand je tape ta 2éme formule, si ma premiére cas est vide, il me met 52!!

à tu une idée du pourquoi?

Merci ;;))
Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
5 489
Bonjour (et salut Eric)
probablement parce que, lorsqu'une cellule est vide, Excel la situe au tout début de Janvier 1900 ce qui pour lui s'inclue dans la S52 en ISO et S0 sans
pour éviter ça:
=SIERREUR(SI(A2="";"";NO.SEMAINE.ISO(A2));"")
crdlmnt
>
Messages postés
25313
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020

Super génial les gars.
Merci beaucoup pour votre aide et votre rapidité.

Bon week-end.

;;;;;;;;)))))))))
Messages postés
23499
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 septembre 2020
6 360
Dans ce cas on peut enlever le sierreur puisque la cause est éliminée :
=SI(A2="";"";NO.SEMAINE.ISO(A2))

suffira
eric
MERCI pour l'info ;)