Google sheet tirage aléatoire affichage texte [Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 13 septembre 2019
Statut
Membre
Dernière intervention
13 septembre 2019
-
Messages postés
2768
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 septembre 2020
-
Bonjour,

Bonjour,

Je suis en train de me faire un petit fichier sur google sheet l'objectif est d'afficher un choix aléatoire dans une case via une liste de choix avec cette formule

=INDEX(Plagenommée;ALEA.ENTRE.BORNES(1;LIGNES(Plagenommée)))

Plagenommée
Choix1
Choix2

j'aimerai que face a ma plage nommé faire un autre choix aletoire "Option" dans une autre case

=INDEX(option;ALEA.ENTRE.BORNES(1;LIGNES(option)))

Plagenommée
option1
option2

Le rendu final :

Choix1 option1
Choix2 option2


Je souhaiterai integrer que si dans la "plagenommée option" que si le terme choix1 apparait la case apparaisse vide sans texte


Pouvez vous m'aider
Par avance merci

Configuration: Windows / Chrome 76.0.3809.132

1 réponse

Messages postés
2768
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 septembre 2020
725
Bonjour

Je ne sais pas si j'ai bien tout compris dans la dernière phrase ???
Si la case choix est "choix1" la case option reste vide.

J'ai fait ça sur excel mais les formules devraient être les mêmes





En espérant avoir vu juste

Cordialement
Messages postés
3
Date d'inscription
vendredi 13 septembre 2019
Statut
Membre
Dernière intervention
13 septembre 2019

J'ai integrer

=SI(D6="Salle";"N/A";INDEX(Couloir;ALEA.ENTRE.BORNES(1;LIGNES(Couloir))))

si la case D6 affiche le mot salle alors afficher "N/A" sinon tirage table aléatoire Couloir

cela ne fonctionne pas
Messages postés
2768
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 septembre 2020
725 >
Messages postés
3
Date d'inscription
vendredi 13 septembre 2019
Statut
Membre
Dernière intervention
13 septembre 2019

Re:
J'ai reproduit mon exemple sur sheets avec l'intégration de N/A et ça fonctionne normalement

A vérifier si le mot "Salle" est exactement orthographié comme dans la liste nommée


Cordialement
Messages postés
2768
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 septembre 2020
725
désolé mais mon image ne veux se charger dans la bonne taille
alors je l'envoie via cjoint.com

https://www.cjoint.com/c/IInopxmopsC
Messages postés
3
Date d'inscription
vendredi 13 septembre 2019
Statut
Membre
Dernière intervention
13 septembre 2019

Je ne comprends pas pourquoi ca ne marche pas

Voila ce que sa donne quand le mot salle apparait ne rien afficher N/A

Salle Couloir tres Long (1d10) - Porte a gauche
Couloir Couloir Long (1d8) - Porte a droite et au fonds
Couloir Couloir moyen (1d6) - Porte a droite
Salle Couloir Long (1d8) - Porte a droite et a gauche

=SI(D6="Salle";"N/A";INDEX(Couloir;ALEA.ENTRE.BORNES(1;LIGNES(Couloir))))

Est ce que le fait que la description d'un couloir soit une plage pose probleme?
Messages postés
2768
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 septembre 2020
725
As-tu bien vérifié comme je le préconisais que le mot salle est correctement écrit, vérifie également si dans la liste nommée il n'y a pas un espace avant ou après le mot.
Cordialement