SSL_ERROR_MISSING_ESNI_EXTENSION [Résolu]

Signaler
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020
-
Messages postés
178855
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
6 juillet 2020
-
Bonjour,

J'ai suivis un tuto pour changer le DNS sur Firefox,j'ai mis Cloudflare DNS.
Dans about config il y a ces réglages:
network.security.esni.enabled;true
network.trr.bootstrapAddress;1.1.1.1
network.trr.custom_uri;https://mozilla.cloudflare-dns.com/dns-query
network.trr.mode;2
network.trr.uri;https://mozilla.cloudflare-dns.com/dns-query

Sur certains site j'ai un message d'erreur:SSL_ERROR_MISSING_ESNI_EXTENSION
j'ai également ce message quand veut aller sur le site de Cloudflare.
J'ai regarder si il y avais des solutions sur le net,plusieurs personne on ce problème,mais cela reste sans solution.Quelqu'un sait d’où cela peut venir?

Autre question:faut il aussi paramétrer le DNS dans Windows et/ou dans la box?ou le paramétrage dans Firefox suffit-il?

J'ai une Freebox mini4K,mais j'utilise le plus souvent la 4g de mon TEL car meilleurs débit.Mais il y a le même problème peut importe le réseau.

Merci




Configuration: Windows 10,Firefox.

A voir également:

3 réponses

Messages postés
178855
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
6 juillet 2020
21 419
Salut,

Remets les valeurs par défaut ou réinitialise Firefox.
et suis ce tuto : https://www.malekal.com/securiser-connexions-dns-firefox-chrome/

Messages postés
178855
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
6 juillet 2020
21 419 >
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020

Non ça n'a rien à voir.
Après tu as peut-être un antivirus qui analyse les connexions HTTPS et ça met le bazar.
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020
116
aussi simple que ça,j'ai désactiver l'analyse HTTPS de NOD32,les test passe sur cloudflare et plus de blocage de site.
C'est safe de laisser l'option désactiver?
Messages postés
178855
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
6 juillet 2020
21 419 >
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020

Pas trop mais les analyses HTTPS des antivirus, ça met la pagaille.
Donc à toi de voir.
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020
116
Ok merci ,je vais approfondir le sujet par rapport a ce qu'explique brupala
Messages postés
92138
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
6 juillet 2020
9 947 >
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020

Lecture:
https://lafibre.info/cryptographie/encrypted-sni/
Cloudflare est en train de se faire son internet dans son coin, le problème c'est qu'ils sont ricains et qui dit ricain dit NSA.
Messages postés
92138
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
6 juillet 2020
9 947
Salut,
un navigateur n'a pas à se mêler des dns les requêtes dns sont gérées par le système, il a un cache pour ça et un fichier hosts.
savoir où configurer les dns, c'est fonction de où il doit s'appliquer, le plus large, donc dans la box, est le mieux, car elle a un cache aussi et donc va optimiser les recherches et réduire les temps d'attente.
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020
116
salut,
Merci pour ces précisions.Mais si je configure seulement la box les connections ne son pas sécurisés.
il y a une option DNS via HTTPS dans firefox qui permet de les sécurisés.
Messages postés
92138
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
6 juillet 2020
9 947 >
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020

Les dns se sécurisent entre eux, pas avec leurs clients.
Encore une fois, ce n'est pas à Firefox d'interroger les dns, c'est pénible cette propagation de l'anarchie, sous prétexte de contrôler, on ouvre de gigantesques failles car personne ne sait la cuisine que fait le navigateur, surtout dans un canal chiffré, alors qu'il est bien plus facile de vérifier ce que fait le système sur des échanges en clair.
En prétendant se protéger on s'enferme dans la manipulation sectaire.
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020
116
Je comprend,mais alors pourquoi il y a ou a quoi sert cette option de Firefox?
Messages postés
92138
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
6 juillet 2020
9 947 >
Messages postés
1145
Date d'inscription
mercredi 26 septembre 2007
Statut
Membre
Dernière intervention
13 mars 2020

Inquiétant sur leur rôle actuel, c'est vrai.
Bonjour,
en remettant ces valeurs par défaut dans about:config ?
network.trr.mode
network.security.esni.enabled

Le tuto de malekal.com pour Firefox me bloque cloudflare avec le même message que toi
SSL_ERROR_MISSING_ESNI_EXTENSION
Messages postés
2
Date d'inscription
jeudi 1 août 2019
Statut
Membre
Dernière intervention
2 août 2019

j'ai également ce message quand veut aller sur le site de Cloudflare.
Messages postés
178855
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
6 juillet 2020
21 419
Salut,

Tu as quel antivirus installés ?
Tu as bien les DNS de CloudFlare dans ton interface réseau ?