Problème #VALEUR! sur une colonne [Résolu/Fermé]

Signaler
-
 AWM -
Bonjour,

Je réalise actuellement un planning de congés et des heures pour des employés mais j'ai un problème.
En faite dans chaque case je rentre le nombre d'heures qu'il effectuera dans la journée et si il n'est pas là, je met dans le cellule le " C ". Mon problème étant que si j'indique par exemple pour le Lundi 1 une journée de 8h à mon technicien, alors ma case "Nombre de congés" va s'incrémenter de 1 or je ne veux pas et les 8h ne seront pas indiqué dans la case "Nombre d'heures".

Voici une photo de ma ligne : https://image.noelshack.com/fichiers/2019/27/5/1562331868-cge.png

J'aimerai que les congés compte pour 0 dans la case "Nombre d'heure" pour ne pas avoir le #VALEUR! et que les heures rentrées ne s'ajoutent pas dans la case "Nombre de congés".

J’espère avoir été assez clair, à noté que je ne suis pas un pro d'excel.

Merci





Configuration: Windows / Chrome 75.0.3770.100

2 réponses

Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Bonjour

Ton image n'indique aps les formules utilisées et ne sert donc à rien
Il faut poster ton fichier sur mon-partage.fr, faire créer un lien, le copier et revenir le coller ici

Quoi qu'il en soit si pour le nombre d'heure tu utilises la formule =SOMME(plage de cellules les C ne seront pas comptés et pas d'erreur VALEUR
Et pour compter les jours de congés tu dois utiliser la formule = NB.SI(plage de cellules;"C")

Cdlmnt
Via
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56912 internautes nous ont dit merci ce mois-ci

Messages postés
29327
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
6 août 2020
6 588
Bonjour,


Nombre de C :
=NB.SI(A3:F3;"C")


Somme si non C :
=SOMME.SI(A3:F3;"<>C") 


Cette dernière fonction est en fait un bug, car si la cellule contient A, cela ne gène pas la somme ;-)
>
Messages postés
29327
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
6 août 2020

Merci beaucoup ca fonctionne mais cependant j'utilise le C pour les congés, M pour maladies ainsi que P pour personnalisé, quelle est la syntaxe pour les ajoutés ?

Cdt,
Messages postés
29327
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
6 août 2020
6 588 > AWM
si totaux individuels :
=NB.SI(A3:F3;"M")
ou
=NB.SI(A3:F3;"P")


si total général :
=NB.SI(A3:F3;"C")+NB.SI(A3:F3;"M")+NB.SI(A3:F3;"P")
>
Messages postés
29327
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
6 août 2020

C'est bon c'est fonctionnel, merci beaucoup !
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bonjour
il suffit d'ajouter les NB.SI
=NB.SI(A3:F3;"C")+NB.SI(A3:F3;"M")+NB.SI(A3:F3;"P")
ou alors de compter les différentes de vide:
=NB.SI(A3:F3;"<>")
crdlmnt
>
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020

Salut, c'est fonctionnel merci de ton aide