Raspbery pi 3B+ + Cisco PacketTracer => Impossible d'éxécuter

[Fermé]
Signaler
Messages postés
3
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
29 juin 2019
-
Messages postés
3
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
29 juin 2019
-
Bonjour à tous,

Je suis un grand novice de Linux et je fais mes débuts sur un Raspbery pi 3B+ (donc en 64bits si je ne m'abuse)
Actuellement en formation de TSSR je voudrai pouvoir utiliser Cisco PacketTracer sur mon Raspi qui tourne sur Raspbian mais je bute sur un message d'erreur lorsque je souhaite lancer mon PacketTracer
Je précise que j'ai bien pris la version linux de PacketTracer

root@raspberrypi:/opt/pt/bin# ./PacketTracer7
bash: ./PacketTracer7 : impossible d'exécuter le fichier binaire : Erreur de format pour exec()

root@raspberrypi:/opt/pt/bin# file ./PacketTracer7
./PacketTracer7: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=8021c991056b7d858a6c6b975d798a8ae8cdf49f, not stripped

root@raspberrypi:/opt/pt/bin# lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.9 (stretch)
Release: 9.9
Codename: stretch


Est-ce que quelqu'un sait s'il faut que j'installe des paquets pour faire tourner correctement cette ap ? Ou si c'est juste pas compatible sur raspbian ou si y a moyen de bidouiller?
Merci pour votre aide.

1 réponse

Messages postés
28789
Date d'inscription
vendredi 5 février 2010
Statut
Modérateur
Dernière intervention
2 mars 2021
9 377
Salut,

C'est un souci d'architecture. Tu as de l'ARM 64 bits, pas du x86_64.

Or, à priori pas compatible avec de L'ARM, malgré le 64 bits.
Messages postés
3
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
29 juin 2019

merci Judge
Je ne savais pas qu il y avait un soucis de compatibilité de processeur.