Installation ubuntu sur disque MBR en dualboot windows 10 [Résolu/Fermé]

Signaler
Messages postés
82
Date d'inscription
lundi 17 août 2015
Statut
Membre
Dernière intervention
22 novembre 2020
-
 Ubi-kitty -
Bonjour,
Je possède un ordinateur portable avec Windows 10 installé.
Je souhaite installer en dual boot xubuntu.
En lançant l utilitaire d installation de xubuntu , l installation de Windows 10 n'est pas reconnue ("aucun os installé ").
J ai poursuivi malgré cela l installation , préparé les partitions mais une fois personnalisé le type d installation , au moment de lancer l installation j ai le message d'erreur suivant :
No EFI System Partition was found . This system will likely not be able to boot successfully, and the installation process may fail. Please go back and add an EFI System Partition , or continue at your own risk.

Du coup la je ne continue pas l installation . ...

Est que cela signifie que je ne peux pas faire mon installation avec mon disque MBR ??!!

Merci d avance pour votre aide...





Configuration: Android / Chrome 73.0.3683.90

3 réponses

Salut,

Depuis le liveUSB, fais un rapport boot-info.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Bonjour,
Vois ici :
https://doc.ubuntu-fr.org/tutoriel/boot-info

Sinon le retour de la commande

sudo parted -l
nous permettra de vérifier le format du disque.
Messages postés
82
Date d'inscription
lundi 17 août 2015
Statut
Membre
Dernière intervention
22 novembre 2020

Bonjour
Réponse de la commande :
Partition table : msdos
Messages postés
82
Date d'inscription
lundi 17 août 2015
Statut
Membre
Dernière intervention
22 novembre 2020

Bonjour
En réponse à kitty, je ne sais pas comment faire pour booter la cle en mode legacy :
- est ce avec la même cle ? (Elle est identifiée dans le bios par "UEFI : ....")
- Dans le bios j ai trouvé un paramètre UEFI boot que j ai donc testé en disabled : cela n a eu pour effet que de ne plus identifier la cle usb en boot option
- Dans le bios il y a egalement un parametre "legacy usb support" mais j ai vu sur un site qu il fallait trouver un paramètre "legacy boot support " ou "CSM support " . Je n'en trouve aucun des 2. Faut il une maj du bios ?

JE CROIS QUE J AI TROUVÉ !!?!
En même temps que je tapais ce message je farfouillais le bios et dans le menu save&exit j ai des options "boot override" ou il y a : le disque dur , "UEFI : ...." la cle usb quoi, et directement la cle usb ! ( sans UEFI devant ).
Et en faisant ce dernier choix , la cle usb est amorcee et windows est detecte par l applicatif d installation de Ubuntu !

Pouvez vous me confirmer ? ( J ai pas lance l installation je dois partir la, je pousuivrai la manip plus tard )
Depuis un terminal, tape cette commande :

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

Si elle retourne "session non efi", tu peux lancer l'installation.
Messages postés
82
Date d'inscription
lundi 17 août 2015
Statut
Membre
Dernière intervention
22 novembre 2020

salut
résultat de la commande :

xubuntu@xubuntu:~$ [ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"
Session non-EFI

--> Impec !
Merci !!!
Messages postés
82
Date d'inscription
lundi 17 août 2015
Statut
Membre
Dernière intervention
22 novembre 2020

Ca y est c est installé ! Merci pour votre aide et.... a bientôt je pense !!!!car je vais avoir besoin de votre aide lol : à peine démarré je m aperçois qu il n y a pas gparted et que pour l installer il faut déjà savoir quoi télécharger ! Les fichiers sur le disque Windows sont toujours verrouillés ! Et dans toutes les manip que j ai faites pour mes problèmes , j ai vu que la partition Windows est vue avec des erreurs par fsck par Ubuntu , mais me dit qu'il faut réparer les erreur par chkdsk sur Windows mais même en ayant fait cela , fsck trouve toujours des erreurs. ...
Slu,

- gparted est dans les paquets et il est installable via la logithèque ou par sudo apt install gparted
- si la partition windows est verrouillée, il faut désactiver l'hibernation depuis Ws par la commande powercfg -h off
- pour fsck, pas d'idée.