Calcul imbriqué [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
vendredi 14 juin 2019
Statut
Membre
Dernière intervention
4 septembre 2019
-
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
-
Bonjour,
je ne sais pas comment faire pour calculer ceci:
selon qu'une des cellules C2 à C10 soit vide ou pleine faire le calcul suivant:

=NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")

sinon mettre 0.

Merci pour votre aide.

2 réponses

Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
Bonjour

si vous voulez 0 alors que n'importe quelles cellules C2:C10 est vide:
=SI(NB.SI(C2:C10;"");0;NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00"))
crdlmnt
Messages postés
7
Date d'inscription
vendredi 14 juin 2019
Statut
Membre
Dernière intervention
4 septembre 2019

Bonjour,
merci pour la réponse, mais elle ne change rien à mon problème! Comment puis-je vous envoyer le fichier pour que vous voyez de quoi je parle. car il se peut que je m'exprime mal à ce sujet?
Messages postés
7
Date d'inscription
vendredi 14 juin 2019
Statut
Membre
Dernière intervention
4 septembre 2019

je vais réécrire ma demande

si la valeur en C2 ou C3 ou C4 jusqu'à C10 différents de rien alors faire NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")) sinon 0
Messages postés
17230
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 septembre 2020
4 246
Bonjour,

essaye comme cela voir
=SI(NBVAL(D2:D10)>0;NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00");"")
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
alors c'est que vos explications ne sont pas suffisantes, en particulier pour ce qui concerne C2 à C10. Voyez pour déposer un modèle ici:
http://mon-partage6fr
en expliquant dedans ce que vous attendez
et en revenant coller le lien créé sur le site
Messages postés
7
Date d'inscription
vendredi 14 juin 2019
Statut
Membre
Dernière intervention
4 septembre 2019
>
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020

si la valeur en C2 ou C3 ou C4 jusqu'à C10 différents de rien alors faire NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00");0)

Le total en B29 C29 D29 E29 est en fonction des valeurs du tableau correspondant.
Celles qui sont en B18 à B28, correspondent aux critères des colonnes D, F, G, de 2 à 10 selon les horaires de 5:00 à 13:00 et 13:00 à 21:00, à la condition qu'une cellule allant de 2 , ou 10 dans colonne C soit vide. C'est le fait qu'elle soit vide ou pas qui déclenche le calcul.

il me faudrait une formule du genre =SI(C2:C10="";NB.SI.ENS($D$2:$D$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($F$2:$F$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00")+NB.SI.ENS($G$2:$G$10;$A17;$A$2:$A$10;">5:00";$A$2:$A$10;"<13:00");0)
Mais avec SI(C2:C10="" ça ne fonctionne pas!!

Merci pour votre aide!!!

Voici le lien
https://mon-partage.fr/f/HrUyTcMo/
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
Bon, j'ai le fichier, mais ce que vous dites est contradictoire:
1° version: on applique la formule si C2ouC3 jusqu'à C10 différents de rien
2° partie: la formule commencerait par SI(C2:C10="".. pour appliquer la formule
Dans tous les cas:
si vous voulez appliquez la formule si C2:C10 est complétement vide, commencez par:
=SI(NB.SI(C2:C10;"");formule)
et si vous la voulez quand C2:C10 est complètement plein
=SI(NB.SI(C2:C10;"<>");formule)
et si vous voulez traiter ligne par ligne pour que la formule ne s'applique que s'il y a un nom en C, incluez un item de plus dans chaque NB.>SI.ENS, soit:
......;$C$2:$C$10;"<>";...)
ou bien sur à l'inverse
......;$C$2:$C$10;"";....)
crdlmnt
Messages postés
7
Date d'inscription
vendredi 14 juin 2019
Statut
Membre
Dernière intervention
4 septembre 2019
>
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020

Merci pour l'aide!!!
J'ai complètement oublié les multicritères de la fonction NB.SI.ENS. Merci milles fois!!!!!
Messages postés
25300
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
Pas de quoi (je suppose que c'est la dernière version de mon message qui vous a mis la puce à l'oreille)
si cela vous convient, merci de passer le sujet en résolu
(menu roue dentée, en haut à droite du titre du fil)
bonne route
crdlmnt