Petit problème annexe [Résolu/Fermé]

Signaler
Messages postés
63
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
27 février 2020
-
 jelobou -
Bonjour,

à la suite de la question que j'ai posée ce matin, j'ai un petit souci d'affichage que j'aimerai régler.

le fichier exemple montre que lorsque je remplis les cases de la colonne B, tout va bien.
mais lorsque les cases de la colonne B sont vides, apparaît #valeur! dans la colonne D.

https://mon-partage.fr/f/KR4Nhlq7/

merci de m'aider à supprimer ces textes en gardant le résultat bien entendu.

3 réponses

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 490
Bonjour
le problème vient des guillemets en C10:C12. ce sont des textes qu'Excel ne peut pas utiliser pour un calcul
puisque votre Excel est au moins de 2013, écrivez en D10

=SIERREUR(B10/C10);"")
ou si vous voulez 0
=SIERREUR(B10/C10);0)
ou une info si vous le souhaitez entre les guillemets

cette solution traitera à la fois le #VALEUR et le #DIV/0

crdlmnt
Messages postés
63
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
27 février 2020

Bonjour Vaucluse,

je viens de tester la formule et elle fonctionne si j'écris :

=SIERREUR((B10/C10);"")

j'ai ajouté une parenthèse après SIERREUR et ça fonctionne.

merci beaucoup, je pense que mon problème est résolu.
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 490
d'une part il semble que vos cellules soient en format texte, donc formatez en nombre et standard (mais ça peut venir de l'erreur d'écriture expliquée après) et d'autre part j'ai écrit une erreur dans ma proposition
la formule est:
=SIERREUR(B10/C10;"")

une parenrhèse entrop
crdlmnt
Bonsoir

Indique la formule suivante en D4 :
=si(estnum(B4);B4/C4;' ')
Utilise format nombre "pourcentage" pour la cellule D4

et voilà