Somme du produit de 2 colonnes sur 3 (Excel) [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 31 mai 2019
Statut
Membre
Dernière intervention
31 mai 2019
-
Messages postés
3
Date d'inscription
vendredi 31 mai 2019
Statut
Membre
Dernière intervention
31 mai 2019
-
Bonjour,

Je cherche un moyen d'utiliser la fonction SOMMEPROD (ou autre) pour multiplier des cellules disjointes sur une même ligne.

Le calcul basique est pourtant simple (du type =C2*D2+F2*G2+I2*J2+L2*M2) mais je n'ai toujours pas trouvé de solution.

J'ai essayé avec cette formule mais j'obtiens 0 comme résultat :
=SOMMEPROD((MOD(COLONNE($C$3:$N$3);3)=2)*(MOD(COLONNE($C$3:$N$3);3)=1);$C$3:$N$3)


Est-ce que quelqu'un pourrait m'aider ?

Merci d'avance

1 réponse

Messages postés
1938
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
16 août 2019
786
Bonjour,

Tu peux essayer =SOMMEPROD(SIERREUR(C3:L3*D3:M3;0))
à valider par CTRL+MAJ+ENTER puisque qu'elle est matricielle.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 79298 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
vendredi 31 mai 2019
Statut
Membre
Dernière intervention
31 mai 2019

Bonjour,

Merci pour ta réponse. En utilisant SIERREUR j'obtiens cependant toujours 0, soit la valeur définie en cas d'erreur.
Messages postés
1938
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
16 août 2019
786
As-tu suivi précisément ce que j’ai écrit ?
Messages postés
3
Date d'inscription
vendredi 31 mai 2019
Statut
Membre
Dernière intervention
31 mai 2019

Oui c'est bon merci ! Une des cellules n'était pas en format Nombre ;)