Somme du produit de 2 colonnes sur 3 (Excel)

Résolu/Fermé
MrBumbleBee Messages postés 3 Date d'inscription vendredi 31 mai 2019 Statut Membre Dernière intervention 31 mai 2019 - 31 mai 2019 à 05:50
MrBumbleBee Messages postés 3 Date d'inscription vendredi 31 mai 2019 Statut Membre Dernière intervention 31 mai 2019 - 31 mai 2019 à 13:30
Bonjour,

Je cherche un moyen d'utiliser la fonction SOMMEPROD (ou autre) pour multiplier des cellules disjointes sur une même ligne.

Le calcul basique est pourtant simple (du type =C2*D2+F2*G2+I2*J2+L2*M2) mais je n'ai toujours pas trouvé de solution.

J'ai essayé avec cette formule mais j'obtiens 0 comme résultat :
=SOMMEPROD((MOD(COLONNE($C$3:$N$3);3)=2)*(MOD(COLONNE($C$3:$N$3);3)=1);$C$3:$N$3)


Est-ce que quelqu'un pourrait m'aider ?

Merci d'avance

1 réponse

JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 850
31 mai 2019 à 06:38
Bonjour,

Tu peux essayer =SOMMEPROD(SIERREUR(C3:L3*D3:M3;0))
à valider par CTRL+MAJ+ENTER puisque qu'elle est matricielle.

Cordialement
1
MrBumbleBee Messages postés 3 Date d'inscription vendredi 31 mai 2019 Statut Membre Dernière intervention 31 mai 2019
Modifié le 31 mai 2019 à 13:32
Bonjour,

Merci pour ta réponse. En utilisant SIERREUR j'obtiens cependant toujours 0, soit la valeur définie en cas d'erreur.
0
JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 850
31 mai 2019 à 13:28
As-tu suivi précisément ce que j’ai écrit ?
0
MrBumbleBee Messages postés 3 Date d'inscription vendredi 31 mai 2019 Statut Membre Dernière intervention 31 mai 2019
31 mai 2019 à 13:30
Oui c'est bon merci ! Une des cellules n'était pas en format Nombre ;)
0