Problèmatique =SI + ARRONDI.SUP avec des valeurs non numerique

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
jeudi 23 mai 2019
Statut
Membre
Dernière intervention
23 mai 2019
-
Messages postés
3
Date d'inscription
jeudi 23 mai 2019
Statut
Membre
Dernière intervention
23 mai 2019
-
Bonjour à tous,

Ça fait quelques jours que je cherche et ne trouve pas de solution a ma problèmatique.

Voici le problème:

Je cherche a effectuer une formule qui ressemble a ceci: =SI(E2="non";ARRONDI.SUP(F2, 0);F2, 2)
Si la valeur de E2 est non, la celulle arrondi a l'entier superieur la celulle F2, sinon, l'affiche tel quel.

dans quelle direction devrais-je chercher?

Merci a tous

3 réponses

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
Bonjour
=SI(E2="non";ARRONDI.SUP(F2, 0);F2)
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
52
Date d'inscription
mardi 14 mai 2019
Statut
Membre
Dernière intervention
2 février 2021
167
Bonjour @Tipoulet38,

Tu as presque la bonne formule ! :) (Ou alors j'ai mal compris ta question ^^)

La voici corrigée :

=SI(E2="non";ARRONDI.SUP(F2;0);F2)


En plaçant cette formule dans la cellule
G3
tu aura le déroulement suivant :

Si
E2
est égale à
non
, alors affiche la valeur arrondie au supérieur de
F2
, sinon affiche la valeur de
F2
.

Bon après-midi, Zepines.

Edit : Désoler @Vaucluse, on a posté en même temps :o

Ma réponse vous a été utile ? N’oubliez pas de cliquer sur « Merci » !
Votre problème est résolu ? Alors mettez le en résolu !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
C'est sans problème, mieux vaut deux fois que pas du tout. D'autant plus qu'il y a une faute de frappe dans la mienne
Bien cordialement
Messages postés
3
Date d'inscription
jeudi 23 mai 2019
Statut
Membre
Dernière intervention
23 mai 2019

Merci pour vos réponses!

maintenant que j'ai corrigé la formule, Excel m'indique un message d'erreur de formule.

Dans ma cellule E2, j'ai déjà la formule suivant pour me donné ma valeur :
=SI(A2<>"";RECHERCHEV(A2;Données!A1:E280;4;FAUX);"") (ce qui me donne soit oui ou non)

serait-il possible que la formule entre en conflit avec celle que j'essais d'ajouté?
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
Les formules sont correctes par rapport à vos demandes
Il faudrait nous dire quel est le message qu'Excel vous affiche (sauf que pour la proposition, mieux vaut prendre celle de Zepines, il y a une faute de frappe dans la mienne (la virgule après F2 dans arrondi_ devrait être un point virgule)
Messages postés
3
Date d'inscription
jeudi 23 mai 2019
Statut
Membre
Dernière intervention
23 mai 2019

Haha, l'erreur étais entre 25 et 30cm de l'écran : )