Formule Excel SI ET non fonctionnel [Fermé]

Signaler
-
 Ludovic -
Bonjour,

Je suis en charge de concevoir un planning qui calcule automatiquement les heures travaillées, manquées, etc.

Je souhaite écrire une formule qui indiquerait :

- Si B10 = "Ma" (Mardi) ET si F10 possède "1" dans sa cellule ALORS indiquer VRAI.
- Si B10 = "Ma" (Mardi) ET si F10 possède "0,5" dans sa cellule ALORS indiquer FAUX.

J'ai d'abord écrit comme cela :

=SI(ET(B10="Ma";(TROUVE("1";F10)));"VRAI";SI(ET(B10="Ma";(TROUVE("0,5";F10)));"FAUX";""))

Je vois bien "VRAI" si Mardi + "1" mais quand c'est Mardi + "0,5", j'ai #VALEUR! au lieu de "FAUX".

Mon objectif est d'avoir une seule formule comprenant tous les jours de la semaine.
J'espère que vous pourriez m'aider à y voir clair.

Je vous remercie d'avance.
Bonne journée.

Ludovic


Configuration: Windows / Chrome 74.0.3729.131

5 réponses

Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour

Essayer cette formule

=SI(ET(B10="Ma";F10=1);"VRAI";SI(ET(B10="Ma";F10=0,5);"FAUX";""))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63632 internautes nous ont dit merci ce mois-ci

Bonjour,

Merci de votre réponse.
Cela ne correspond pas à mon souhait.

En effet, j'ai utilisé la fonction TROUVE car le "1" et "0,5" se trouve dans une phrase comme "Congé 1" ou "Congé 0,5", "Arrêt Travail 1", "Arrêt Travail 0,5".

Avec votre formule, mes 1 et 0,5 ne sont donc pas détectés.

Merci de votre intervention, néanmoins :)
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 851
Bonjour à tous les deux

Si en F10 le nombre cherché est à droite (Mardi+1 ou Mardi+0.5 ou Mardi) essaies ceci
=SI(ESTERR(DROITE(F10;NBCAR(F10)-TROUVE("+";F10)));"";SI(ET(B10="Ma";DROITE(F10;NBCAR(F10)-TROUVE("+";F10))="1");"VRAI";SI(ET(B10="Ma";DROITE(F10;NBCAR(F10)-TROUVE("+";F10))="0,5");"FAUX";"")))

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63632 internautes nous ont dit merci ce mois-ci

Bonjour,

Merci de votre intervention.
Le nombre recherché est à gauche dans mon cas.

Je viens tout de même essayer votre formule et ça n'a rien donné, malheureusement.
Merci encore.
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 851
"Le nombre recherché est à gauche dans mon cas.
Je viens tout de même essayer votre formule et ça n'a rien donné, malheureusement. "
Ben oui !!!
Peux tu envoyer un bout de ton fichier sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63632 internautes nous ont dit merci ce mois-ci

Bonjour,

Le voici :

https://www.cjoint.com/c/IErnOdiazIW

La cellule dans laquelle je veux voir "vrai" ou "faux" est en violet dans le tableau.

Merci encore.
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 851
Ce n'est pas un "+" qui sépare le texte du nombre dans tes cellules Fxx
Donc en remplaçant + par un espace dans la formule, ça devrait le faire
=SI(ESTERR(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10)));"";SI(ET(B10="Ma";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="1");"VRAI";SI(ET(B10="Ma";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="0,5");"FAUX";"")))

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63632 internautes nous ont dit merci ce mois-ci

Bonjour,

Cela fonctionne à merveille. Je n'aurais jamais trouvé cela, merci beaucoup !

Comment puis-je "incrémenter" la formule pour avoir tous les jours de la semaine ?

Je fais comme cela, pour Lundi et Mardi par exemple ?

=SI(ESTERR(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10)));"";SI(ET(B10="L";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="1");"VRAI";SI(ET(B10="L";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="0,5");"FAUX";SI(ESTERR(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10)));"";SI(ET(B10="L";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="1");"VRAI";SI(ET(B10="L";DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="0,5");"FAUX";"ETC SUITE (mercredi, jeudi, ...)"))))))
Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 851
As tu vraiment besoin de tester le jour de la semaine ?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63632 internautes nous ont dit merci ce mois-ci

Messages postés
9494
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 juillet 2020
1 851
Par exemple, si tu ne veux pas de valeur pour S et D
=SI(OU(B10="S";B10="D");"";SI(ESTERR(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10)));"";SI(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="1";"VRAI";SI(DROITE(F10;NBCAR(F10)-TROUVE(" ";F10))="0,5";"FAUX";""))))
Bonjour,

Effectivement, j'aurais besoin des jours car mes employés ont de différentes horaires chaque jour.

Merci encore !