Fonction « SOMME.SI.ENS » avec liste de critères dynamique/variable [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019
-
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019
-
Bonjour,

Bonjour à vous tous

J’essaye de sommer avec la fonction ‘SOMME.SI.ENS’ une liste ayant multiple critères
La question c’est que le nbr des critères est variable,
Je vise avoir une formule de somme.si.ens dynamique pour une colonne de critère variable ( j’ai essayé même convertir en tableau pour ajout automatique à la liste des critère mais sans résultat
Ma formule , statique, actuelle qui fonctionne est :
=SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5);SOMME.SI.ENS(B2:B26;A2:A26;F6);SOMME.SI.ENS(B2:B26;A2:A26;F7);SOMME.SI.ENS(B2:B26;A2:A26;F8);SOMME.SI.ENS(B2:B26;A2:A26;F9);SOMME.SI.ENS(B2:B26;A2:A26;F10))

J’ai essayé sans résultat avec :
• =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;Tableau2[Colonne1]))
• =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;OU(F5;F6;F7;F8;F9;F10)))
• =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;F6;A2:A26;F7;A2:A26;F8;A2:A26;F9;A2:A26;F10))
• {=SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;Tableau2[Colonne1]))}

SVP y a une proposition ? et j’essaye d’éviter le VBA




Configuration: Windows / Chrome 73.0.3683.103

2 réponses

Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020
276
Bonjour,

Question posée sur d'autres forums.
Réponse sur un autre forum

Cdlt
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019

lorsque tu es malade tu part pour plusieurs docteur
lorsque tu voulait acheter quelques chose tu part pour multiple centre pour faire la comparaison des prix
pour faire quelque chose que tu savait pas tu demande l'avis de multiple expert non ?

donc c'est le même principe

en tout cas merci pour le temps que vous avez passé à me répondre
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019

pour les successeur de cette discussion , voilà l'excellente solution:

=SOMMEPROD((SOMME.SI.ENS(B2:B26;A2:A26;Tableau2[Colonne1])*1))
Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020
276
lorsque tu es malade tu part pour plusieurs docteur
lorsque tu voulait acheter quelques chose tu part pour multiple centre pour faire la comparaison des prix
pour faire quelque chose que tu savait pas tu demande l'avis de multiple expert non ?

donc c'est le même principe



Ne le prenez pas mal, j'ai simplement voulu éviter aux autres forumeurs de perdre du temps à chercher une solution alors que je vous l'avez déjà donnée ailleurs (même si ce n'est pas le même pseudo).

Vous auriez pu par la même occasion dire si la réponse vous convenait et mettre le sujet en résolu.

Cdlt
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019
>
Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020

la réponse était super efficace , parfaitement ce que je cherchait, et d'ailleur mille merci autre fois

j'ai marqué le sujet résolu la matinée, et je le refait maintenant peut être que ça n'a pas fonctionné auparavant

Autre fois merciii ^^