Résultat suivant 2 conditions

Résolu/Fermé
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019 - 22 avril 2019 à 16:57
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 - 23 avril 2019 à 10:58
Bonjour,
Je souhaiterai obtenir le résultat suivant le mois (P2) et l'arrondissement (Q2).
Et pour la colonne N2 à N23 y a t'il une formule pour obtenir le résultat suivant P2?
https://www.cjoint.com/c/IDwo3TNi5hP
Par avance, merci beaucoup pur votre aide.
Cordialement,
Momo

8 réponses

SioGabx Messages postés 261 Date d'inscription mardi 21 août 2018 Statut Membre Dernière intervention 2 octobre 2022 95
Modifié le 22 avril 2019 à 17:28
Alors pour le résultat en fonction du mois et de de l'arrondissement : =RECHERCHEV(Q2;A3:M23;P2+1)
Pour le résultat N2 à N23 en fonction de P2, en gros tu veux le total pour le mois/arrondissement sélectionné ?
Dans ce cas en adaptant la formule précédente : =RECHERCHEV(Q2;A3:N23;14)
1
SioGabx Messages postés 261 Date d'inscription mardi 21 août 2018 Statut Membre Dernière intervention 2 octobre 2022 95
22 avril 2019 à 17:31
PS pour te total utilise plutôt la formule en N3 que tu peux faire glisser jusqu'en N23 : =SOMME(B3:M3)
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 17:22
Bonjour à tous les deux

Pour la première question
https://www.cjoint.com/c/IDwpv5XQAcB

Pour la deuxième
Il faudra expliquer un peu plus

Cdlmnt
1
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 17:29
Et pour la question 2, peut être ceci
https://www.cjoint.com/c/IDwpC0ait8B
Cdlmnt
0
SioGabx Messages postés 261 Date d'inscription mardi 21 août 2018 Statut Membre Dernière intervention 2 octobre 2022 95
22 avril 2019 à 17:35
Je connaissait pas INDEX, ça à l'air plus propre que moi mais plus difficile x)
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 17:57
La combinaison INDEX-EQUIV s'utilise lorsque la colonne de recherche n'est pas la première du tableau.
Dans notre cas, j'ai dû me laisser aller, RECHERCHEV est plus simple ;-)
0
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 19:00
Je te remercie ccm81, serait-il possible d'obtenir le cumul dans P5 selon le mois et l'arrondissement?
0
Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 17 184
22 avril 2019 à 17:43
" je souhaiterai obtenir le résultat suivant le mois (P2) et l'arrondissement (Q2) "
Tu veux ça en P5 ? Et dans ton exemple ce serait pour le mois de mars (P2), mais pour quel arrondissement ? Quel résultat devrait s'afficher en P5 ?

Si tu veux les 20 résultats en colonne R:R, il faut saisir en R4 la formule
=RECHERCHEV(Q4;$A$3:$N$23;P$2+1;0) et recopier vers le bas.

Je ne sais pourquoi tu as saisi manuellement les valeurs en colonne N:N au lieu d'utiliser une formule d'addition ; d'ailleurs tes valeurs en N3:N6 sont fausses ...
1
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 18:49
Bonjour Raymond, je te remercie de ton aide. Pourrais-tu SVP m'expliquer le (+1;0)? ça correspond à quoi?
Merci encore...
Cordialement,
Momo
0
Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 17 184
22 avril 2019 à 18:57
C'est le N° de colonne.
Le mois de mars (3) est en colonne D (4) ...
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 21:02
Peux tu expliquer ce que tu entends par "cumul" ?
dans P5, je souhaiterai le cumul suivant le mois et l'arrondissement...
Le mieux est de donner un exemple avec le résultat attendu.
1
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 21:13
Exemple si dans le menu déroulant j'ai le mois de février et Paris le cumul sera de janvier à février pour Paris, et pour le même mois si je demande pour le 18ème ça sera le cumul des 2 mois ect...
Merci...
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 21:32
comme ça ?
https://www.cjoint.com/c/IDwtGuLPCHB
0
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 21:42
C'est tout à fait ça... un grand merci à toi et tous.
Afin que je puisse comprendre aurais tu l'amabilité d'interpréter cette formule SVP?
0
ccm81 Messages postés 10464 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 3 octobre 2022 2 318
22 avril 2019 à 21:50
DECALER(Feuil1!$A$2;EQUIV(Feuil1!$Q$2;Feuil1!$A$3:$A$23);1;1;EQUIV(Feuil1!$P$2;Feuil1!$B$2:$M$2;0))
définit dynamiquement la plage
1. à partir de la cellule $A$2
2. dont la première cellule est décalée
2.1. de EQUIV(Feuil1!$Q$2;Feuil1!$A$3:$A$23) lignes < rang de $Q$2 dans la plage $A$3:$A$23>
2.2. et de 1 colonne
3. et contenant
3.1. 1 ligne
3.2. et EQUIV(Feuil1!$P$2;Feuil1!$B$2:$M$2;0) colonnes <rang de $P$2 dans la plage $B$2:$M$2>

Cdlmnt

.
0
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 21:56
En toute sincérité encore un grand merci pour toutes tes explications, je te souhaite une excellente soirée.
Cordialement,
Momo
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 17 184
Modifié le 23 avril 2019 à 01:32
Si ce que tu n'as cessé, avant le post #15, d'appeler "résultat" est en réalité "cumul" ou "somme" , alors la formule en ligne 3 est tout simplement
=SOMME(B3:DECALER(B3;0;$P$2))
C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
1
Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 17 184
22 avril 2019 à 17:11
Bonjour.

Pourrais-tu reformuler tes questions ?
Je n'arrive pas à comprendre ce que tu veux !
0
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 18:42
Merci beaucoup, pour toutes les propositions dans P5, je souhaiterai le cumul suivant le mois et l'arrondissement...
Cordialement,
Momo189
0
momo189 Messages postés 36 Date d'inscription lundi 22 avril 2019 Statut Membre Dernière intervention 10 juin 2019
22 avril 2019 à 19:11
J'ai essayé la formule dans P10 =SOMME.SI(INDEX($B$3:$M$23;EQUIV($Q$2;$A$3:$A$23;0);EQUIV($P$2;$B$2:$M$2;0) celle-ci ne fonctionne pas...
0