Nombre de valeurs différentes dans liste [Résolu/Fermé]

Signaler
Messages postés
202
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
1 juillet 2020
-
Messages postés
12362
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 juillet 2020
-
Bonjour,

voici ma problématique

j'ai une plage de donnée A1:A30 composée de nom de pays qui peuvent revenir.
Par exemple :
A1 : FRANCE
A2 : FRANCE
A3 : ESPAGNE
A4 : ITALIE
A5 : FRANCE
etc

je souhaite obtenir dans une case C1 le nombre de pays différents dans la liste A1:A30.

Est-ce possible ?

Merci

Configuration: Windows / Firefox 60.0

7 réponses

Messages postés
1986
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
4 juillet 2020
313
Bonjour

A mettre en C1 formule matricielle
{=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))}
a valider avec les touches Ctrl+Maj+Entrée
Cordialement
Messages postés
17134
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 116
Bonsoir,

toujours en formule matricielle qui doit être confirmée en cliquant en même temps sur 3 touches du clavier Ctrl, Shift et Entrée
si tu fais bien la formule se placera entre {}
si ta liste n'a pas de cellule vide
=SOMMEPROD(1/NB.SI(A1:A5;A1:A5))

si tu as des cellules vides dans ta colonne
=SOMMEPROD(SI(A1:A30<>"";1/NB.SI(A1:A30;A1:A30)))
ou encore
=SOMME(SI(A1:A30<>"";1/NB.SI(A1:A30;A1:A30)))
Messages postés
202
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
1 juillet 2020

Merci pour vos retours.
Je complexifie un petit peut :
- j'ai en B1:B30 des montants.
- J'aimerais faire un tableau récap des totaux par pays (un peu comme un TCD mais sans faire un TCD).

Ci-joint un exemple de ce que j'aimerais faire.

https://www.cjoint.com/c/IDbuJqisasP
Messages postés
12362
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 juillet 2020
1 916
Bonsoir

Là c'est plus simple il suffit d'un SOMME.SI
=SOMME.SI($A$3:$A$14;D3;$B$3:$B$14)
Bien respecter les $ aux bons endroits et étirer la formule vers le bas

Cdlmnt
Via
Messages postés
51876
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 585
Même réponse que mon ami via55 :
https://www.cjoint.com/c/IDbxHelowxb

Salut à vous deux.
Messages postés
202
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
1 juillet 2020

merci à vous deux.
La question de la somme est réglée.
Par contre les pays qui seront renseignés ne sont pas prédéfinis. Donc y a-t-il un moyen d'alimenter la plage J3:J7 dans le fichier de Raymond PENTIER en fonction des des valeurs saisies dans le premier tableau ?
Messages postés
51876
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 585

! ! !

On dirait que tu n'as pas lu mes explications :
Messages postés
202
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
1 juillet 2020

Merci Raymond pour ta réponse. J'avais bien vu ton commentaire mais je souhaitais une solution sans manipulation de suppression de doublons.
Messages postés
12362
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 juillet 2020
1 916
Bonjour à vous deux

Pour obtenir une liste sans doublons il faut des formules matricielles (dans la colonne J) qui sont validées par CTRL+MAJ+Entrée (les formules se mettent alors auto entre accolades dans la barre de formules
https://mon-partage.fr/f/rTYlcbEV/

Cdlmnt
Via
Messages postés
202
Date d'inscription
samedi 24 novembre 2012
Statut
Membre
Dernière intervention
1 juillet 2020

Super, c'est exactement ce que je voulais.
Peux tu m'expliquer un peut la formule ?
Messages postés
12362
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 juillet 2020
1 916
re,

Je serai bien en peine de te l'expliquer, c'est une formule que j'avais trouvé sur CCM !
Elle fonctionne c'est l'essentiel