Formule trie

Résolu/Fermé
Factory26 Messages postés 10 Date d'inscription mardi 19 février 2019 Statut Membre Dernière intervention 20 février 2019 - 19 févr. 2019 à 16:52
Factory26 Messages postés 10 Date d'inscription mardi 19 février 2019 Statut Membre Dernière intervention 20 février 2019 - 20 févr. 2019 à 22:51
Bonjour,

j'ai un tableau avec 6 résultats je souhaite que dans ma colonne Total ça ne me prenne en compte que les 3 meilleurs sur les 6.
Qu'elle formule dois je utiliser ?
Merci d'avance

Configuration: Windows / Chrome 72.0.3626.109

1 réponse

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 392
Modifié le 19 févr. 2019 à 17:00
Bonjour
pour un champ de A1 à A6, à adapter:
=SOMMEPROD((A1:A6>=GRANDE.VALEUR(A1:A6;3))*(A1:A6))
vous additionnera les éventuels ex-aequo autant de fois qu'ils sont présents dans la condition
crdlmnt

0
Factory26 Messages postés 10 Date d'inscription mardi 19 février 2019 Statut Membre Dernière intervention 20 février 2019
19 févr. 2019 à 17:07
les colonnes à trier ne sont pas à la suite du coup ça ne fonctionne pas en sélectionnant directement.
ex: résultat 1 en M,5 2e O5, 3e en Q5, 4e S5, 5e en U5, et dernier en W5.

je ne sais pas si mes explications sont correct
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 392
Modifié le 19 févr. 2019 à 17:54
elles sont correctes mais ce serait mieux si elles étaient complète! vous avez quoi dans les colonne intercalées?
ou mieux, déposez un modèle de votre problème ici:
http://mon-paratge.fr
et revenez coller le ,lien créé sur le site
à vous lire
crdlmnt
0
Factory26 Messages postés 10 Date d'inscription mardi 19 février 2019 Statut Membre Dernière intervention 20 février 2019
Modifié le 19 févr. 2019 à 20:15
Re,

Voici le lien de l'image du tableau :

https://mon-partage.fr/f/1A6r19vu/

je souhaiterai donc pouvoir dans la colonne Total, que ça sélectionne parmi la colonne M O Q S U W les 3 meilleurs résultats.

Merci d'avance
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 392
20 févr. 2019 à 08:03
Bonjour
voyez ici une des deux options et revenez si problème
https://mon-partage.fr/f/7pCSJ067/
crdlmnt
0
Factory26 Messages postés 10 Date d'inscription mardi 19 février 2019 Statut Membre Dernière intervention 20 février 2019
20 févr. 2019 à 08:34
Bonjour,
Super nickel ça fonctionne. Je vous remercie de votre temps et réponse.
cordialement
0